刻意用卷包裹法写了一个凸包问题。
Wall
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 22839 | Accepted: 7492 |
Description
Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall.
Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements.
The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.
Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements.
The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.
Input
The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle.
Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.
Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.
Output
Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.
Sample Input
9 100 200 400 300 400 300 300 400 300 400 400 500 400 500 200 350 200 200 200
Sample Output
1628
Hint
结果四舍五入就可以了
#include<iostream>
#include<cmath>
#include<cstdio>
#include<complex>
#include<cstring>
#include<string>
#include<algorithm>
#include<iomanip>
using namespace std;
#define max(a,b) (a>b?a:b)
#define min(a,b) (a<b?a:b)
#define eps 1e-8
#define zero(x) (((x)>0?(x):-(x))<eps)
const double pi=acos(-1.0);
struct point { double x,y; };
struct line { point a,b ; };
#define MAXN 1100
int n,r;
point p[MAXN];
int conv[MAXN];
bool used[MAXN];
int len;
//比较距离
int sig(double k)
{
//return k<-eps?-1:k>eps;
if(fabs(k)<eps)
return 0;
return (k>0)?1:-1;
}
double distances(point a, point b) //点距离
{
return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
//叉积
double xmult(point a,point b ,point c)
{
return (a.x-c.x)*(b.y-c.y)-(b.x-c.x)*(a.y-c.y);
}
//与原点叉积
double cross(point a,point b)
{
return a.x*b.y-a.y*b.x;
}
//找出最左下的点
bool cmp(point a,point b)
{
return ( a.y<b.y || a.y==b.y&&a.x<b.x );
}
//p0p1是否在p0p2左边 (在左边返回-1 重合返回0 在右边返回1)
int turn_left(point p0,point p1, point p2)
{
return sig(xmult(p1,p2,p0));
}
//卷包裹法
void convex()
{
int top,index,first;
memset(used,0,sizeof(used));
sort(p,p+n,cmp);
first=0; //最左下角坐标
top=0;
index=-1;
used[0]=true;
conv[top++]=0;
while(1)
{
index=-1;
for(int i=0;i<n;i++)
{
if(used[i])
continue;
index=i;
break;
}
if(index==-1) //只有一个点的时候
{
conv[top++]=0;
break;
}
for(int i=0;i<n;i++)
{
if( !used[i] && i!=index && (turn_left(p[conv[top-1]],p[i],p[index])==1||
turn_left(p[conv[top-1]],p[i],p[index])==0&& distances(p[conv[top-1]],p[i])<distances(p[conv[top-1]],p[index])))
index=i;
}
if(turn_left(p[conv[top-1]],p[0],p[index])==1)
{
conv[top++]=0;
break;
}
used[index]=1;
conv[top++]=index;
}
len=top-1;
}
double solve()
{
double length=0;
for(int i=0;i<len;i++)
length+=distances(p[conv[i]],p[conv[i+1]]);
length+=2*pi*r;
return length;
}
void init()
{
len=0;
for(int i=0;i<n;i++)
scanf("%lf%lf",&p[i].x,&p[i].y);
}
int main()
{
while(cin>>n>>r)
{
init();
convex();
cout<<setprecision(0)<<setiosflags(ios::fixed)<<solve()<<endl;
}
return 0;
}