POJ 3159 Candies 差分约束

23 篇文章 0 订阅
8 篇文章 0 订阅
一开始没有读懂题目意思,最后看了题目的解释才知道是要我们求flymouse最多比snoopy多拿多少糖。
这就是一道简单的差分约束,只是这里要注意。。我用vector容器超时了,但是换成自己写的邻接表就过了。。。。没法偷懒了,另外这里似乎用spfa的话一定要用堆栈,否则好像也是tle。
这题我写了两种算法一种是spfa+堆栈,另一种是dijkstra的堆优化,这里贴上spfa的代码
Candies
Time Limit: 1500MS Memory Limit: 131072K
Total Submissions: 18611 Accepted: 4896

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integersN and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 throughN. snoopy and flymouse were always numbered 1 and N. Then followM lines each holding three integers A, B and c in order, meaning that kidA believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5
#include<iostream>
#include<vector>

using namespace std;

#define MAXN 30100
#define MAXM 150010
#define INF  0xFFFFFF

struct node
{
	int to,dis;
	int next;
}e[MAXM];

int n,m;
int top,num;
int stack[MAXN],g[MAXN];
bool in[MAXN];
int dis[MAXN];


void add(int a,int b,int c)
{
	e[num].to=b;
	e[num].dis=c;
	e[num].next=g[a];
	g[a]=num++;	
}

void init()
{
	num=1;
	node temp;
	int a,b,c;
	for(int i=0;i<=n;i++)
		g[i]=-1;
	for(int i=1;i<=m;i++)
	{
		scanf("%d%d%d",&a,&b,&c);
		add(a,b,c);
	}
}

void spfa(int s)
{
	top=0;
	int tag;
	for(int i=1;i<=n;i++)
	{
		in[i]=false;
		dis[i]=INF;
	}
	in[s]=true;
	stack[++top]=s;
	dis[s]=0;
	while(top!=0)
	{
		tag=stack[top--];
		in[tag]=false;
		for(int i=g[tag];i!=-1;i=e[i].next)
		{
			int j=e[i].to;
			if(dis[j]>dis[tag]+e[i].dis)
			{
				dis[j]=dis[tag]+e[i].dis;
				if(!in[j])
				{
					in[j]=true;
					stack[++top]=j;
				}
			}
		}
	}
	printf("%d\n",dis[n]);	
}

int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		init();
		spfa(1);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值