POJ2175 Evacuation Plan 消圈算法

此题不能直接用费用流,会TLE,因为只要输出比方案好的解即可,所以进行一次消圈就可以了
Evacuation Plan
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2401 Accepted: 616 Special Judge

Description

The City has a number of municipal buildings and a number of fallout shelters that were build specially to hide municipal workers in case of a nuclear war. Each fallout shelter has a limited capacity in terms of a number of people it can accommodate, and there's almost no excess capacity in The City's fallout shelters. Ideally, all workers from a given municipal building shall run to the nearest fallout shelter. However, this will lead to overcrowding of some fallout shelters, while others will be half-empty at the same time.

To address this problem, The City Council has developed a special evacuation plan. Instead of assigning every worker to a fallout shelter individually (which will be a huge amount of information to keep), they allocated fallout shelters to municipal buildings, listing the number of workers from every building that shall use a given fallout shelter, and left the task of individual assignments to the buildings' management. The plan takes into account a number of workers in every building - all of them are assigned to fallout shelters, and a limited capacity of each fallout shelter - every fallout shelter is assigned to no more workers then it can accommodate, though some fallout shelters may be not used completely.

The City Council claims that their evacuation plan is optimal, in the sense that it minimizes the total time to reach fallout shelters for all workers in The City, which is the sum for all workers of the time to go from the worker's municipal building to the fallout shelter assigned to this worker.

The City Mayor, well known for his constant confrontation with The City Council, does not buy their claim and hires you as an independent consultant to verify the evacuation plan. Your task is to either ensure that the evacuation plan is indeed optimal, or to prove otherwise by presenting another evacuation plan with the smaller total time to reach fallout shelters, thus clearly exposing The City Council's incompetence.

During initial requirements gathering phase of your project, you have found that The City is represented by a rectangular grid. The location of municipal buildings and fallout shelters is specified by two integer numbers and the time to go between municipal building at the location (Xi, Yi) and the fallout shelter at the location (Pj, Qj) is D i,j = |Xi - Pj| + |Yi - Qj| + 1 minutes.

Input

The input consists of The City description and the evacuation plan description. The first line of the input file consists of two numbers N and M separated by a space. N (1 ≤ N ≤ 100) is a number of municipal buildings in The City (all municipal buildings are numbered from 1 to N). M (1 ≤ M ≤ 100) is a number of fallout shelters in The City (all fallout shelters are numbered from 1 to M).

The following N lines describe municipal buildings. Each line contains there integer numbers Xi, Yi, and Bi separated by spaces, where Xi, Yi (-1000 ≤ Xi, Yi ≤ 1000) are the coordinates of the building, and Bi (1 ≤ Bi ≤ 1000) is the number of workers in this building.

The description of municipal buildings is followed by M lines that describe fallout shelters. Each line contains three integer numbers Pj, Qj, and Cj separated by spaces, where Pi, Qi (-1000 ≤ Pj, Qj ≤ 1000) are the coordinates of the fallout shelter, and Cj (1 ≤ Cj ≤ 1000) is the capacity of this shelter.

The description of The City Council's evacuation plan follows on the next N lines. Each line represents an evacuation plan for a single building (in the order they are given in The City description). The evacuation plan of ith municipal building consists of M integer numbers E i,j separated by spaces. E i,j (0 ≤ E i,j ≤ 1000) is a number of workers that shall evacuate from the i th municipal building to the j th fallout shelter.

The plan in the input file is guaranteed to be valid. Namely, it calls for an evacuation of the exact number of workers that are actually working in any given municipal building according to The City description and does not exceed the capacity of any given fallout shelter.

Output

If The City Council's plan is optimal, then write to the output the single word OPTIMAL. Otherwise, write the word SUBOPTIMAL on the first line, followed by N lines that describe your plan in the same format as in the input file. Your plan need not be optimal itself, but must be valid and better than The City Council's one.

Sample Input

3 4
-3 3 5
-2 -2 6
2 2 5
-1 1 3
1 1 4
-2 -2 7
0 -1 3
3 1 1 0
0 0 6 0
0 3 0 2

Sample Output

SUBOPTIMAL
3 0 1 1
0 0 6 0
0 4 0 1
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<cmath> 

using namespace std;

#define MAXN 5000
#define MAXM 1000000
#define INF 0xFFFFFF
struct edge
{
	int to,c,w,next;
};

edge e[MAXM];
bool in[MAXN];
int head[MAXN],dis[MAXN],pre[MAXN],counts[MAXN],en;
int vn,st,ed,n,m;
int ax[MAXN],ay[MAXN],az[MAXN],bx[MAXN],by[MAXN],bz[MAXN],bs[MAXN];
int cost[MAXN][MAXN];

void add(int a,int b,int c,int cc,int d)
{
	e[en].to=b;
	e[en].c=c;
	e[en].w=d;
	e[en].next=head[a];
	head[a]=en++;
	e[en].to=a;
	e[en].c=cc;
	e[en].w=-d;
	e[en].next=head[b];
	head[b]=en++;	
}

int distances(int x1,int y1,int x2,int y2)
{
	return abs(x1-x2)+abs(y1-y2)+1;
}

int spfa(int s)
{

	queue<int> q;
	for(int i=0;i<=vn;i++)
	{
		dis[i]=INF;
		in[i]=false;
		pre[i]=-1;
		counts[i]=0;
	}
	dis[s]=0,in[s]=true,q.push(s);
	counts[s]=1;
	while(!q.empty())
	{
		int tag=q.front();
		q.pop();
		in[tag]=false;
		for(int i=head[tag];i!=-1;i=e[i].next)
		{
			int j=e[i].to;
			if(e[i].c && e[i].w+dis[tag]<dis[j])
			{
				pre[j]=i,dis[j]=e[i].w+dis[tag];
				if(!in[j])
				{
					q.push(j),in[j]=true;
					counts[j]++;
					if(counts[j]>=vn)
						return j;
				}
			}
		}
	}
	return -1;	
}

void update(int p)  
{  
	int flow=INF;
	int i,u=pre[p];
	i=u;
	if(e[u].c<flow) flow=e[u].c;
	for(i=pre[e[i^1].to];i!=u;i=pre[e[i^1].to]) if(e[i].c<flow) flow=e[i].c;
	e[u].c-=flow,e[u^1].c+=flow,i=u;
	for(i=pre[e[i^1].to];i!=u;i=pre[e[i^1].to]) e[i].c-=flow,e[i^1].c+=flow;
}  

void solve()
{
	st=0,ed=n+m+1,vn=n+m+1;
	memset(bs,0,sizeof(bs)),en=0;
	memset(head,-1,sizeof(head));
	for(int i=1;i<=n;i++)
		scanf("%d%d%d",&ax[i],&ay[i],&az[i]);
	for(int i=1;i<=m;i++)
		scanf("%d%d%d",&bx[i],&by[i],&bz[i]);
	for(int i=1;i<=n;i++)
		for(int j=1;j<=m;j++)
			cost[i][j]=distances(ax[i],ay[i],bx[j],by[j]);
	for(int i=1;i<=n;i++)
		for(int j=1;j<=m;j++)
		{
			int tempflow;
			scanf("%d",&tempflow);
			bs[j]+=tempflow;
			add(i,j+n,az[i]-tempflow,tempflow,cost[i][j]);
		}
	
	for(int i=1;i<=m;i++)
		add(i+n,ed,bz[i]-bs[i],bs[i],0);
	int p;
	if((p=spfa(ed))==-1)
	{
		printf("OPTIMAL\n");
		return ;
	}
	memset(in,false,sizeof(in));
	while(!in[p])
	{
		in[p]=true;
		p=e[pre[p]^1].to;
	}
	update(p);
	printf("SUBOPTIMAL\n");
	for(int i=1;i<=n;i++)
		for(int j=1;j<=m;j++)
		{
			printf("%d",e[(((i-1)*m+j-1)*2)^1].c);
			if(j!=m)
				printf(" ");
			else
				printf("\n");
		}
}

int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
		solve();
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值