分别求出一点到起点和终点的最短距离,然后枚举商业线求出起点到终点的最短距离,记录即可。
不看英文原题的要注意两个输出之间要有空行
Time Limit: 1000MS | Memory Limit: Unknown | 64bit IO Format: %lld & %llu |
Description
Problem D: Airport Express |
In a small city called Iokh, a train service, Airport-Express, takes residents to the airport more quickly than other transports. There are two types of trains in Airport-Express, the Economy-Xpressand the Commercial-Xpress. They travel at different speeds, take different routes and have different costs.
Jason is going to the airport to meet his friend. He wants to take the Commercial-Xpress which is supposed to be faster, but he doesn't have enough money. Luckily he has a ticket for the Commercial-Xpress which can take him one station forward. If he used the ticket wisely, he might end up saving a lot of time. However, choosing the best time to use the ticket is not easy for him.
Jason now seeks your help. The routes of the two types of trains are given. Please write a program to find the best route to the destination. The program should also tell when the ticket should be used.
Input
The input consists of several test cases. Consecutive cases are separated by a blank line.
The first line of each case contains 3 integers, namely N, S and E (2 ≤ N ≤ 500, 1 ≤ S, E ≤ N), which represent the number of stations, the starting point and where the airport is located respectively.
There is an integer M (1 ≤ M ≤ 1000) representing the number of connections between the stations of the Economy-Xpress. The next Mlines give the information of the routes of the Economy-Xpress. Each consists of three integers X, Y and Z (X, Y ≤ N, 1 ≤ Z ≤ 100). This means X and Y are connected and it takes Z minutes to travel between these two stations.
The next line is another integer K (1 ≤ K ≤ 1000) representing the number of connections between the stations of the Commercial-Xpress. The next K lines contain the information of the Commercial-Xpress in the same format as that of the Economy-Xpress.
All connections are bi-directional. You may assume that there is exactly one optimal route to the airport. There might be cases where you MUST use your ticket in order to reach the airport.
Output
For each case, you should first list the number of stations which Jason would visit in order. On the next line, output "Ticket Not Used" if you decided NOT to use the ticket; otherwise, state the station where Jason should get on the train of Commercial-Xpress. Finally, print the total time for the journey on the last line. Consecutive sets of output must be separated by a blank line.
Sample Input
4 1 4 4 1 2 2 1 3 3 2 4 4 3 4 5 1 2 4 3
Sample Output
1 2 4 2 5
Problemsetter: Raymond Chun
Originally appeared in CXPC, Feb. 2004
#include<iostream>
#include<cstring>
#include<cstdio>
#include<string>
#include<algorithm>
#include<queue>
#define MAXN 2000
#define INF 0x3F3F3F3F
using namespace std;
struct node
{
int to;
int dis;
int next;
}edge[MAXN*MAXN];
bool in[MAXN];
int head[MAXN],en;
int dis[2][MAXN];
int path[2][MAXN];
int n,s,e,m,k;
void add(int u,int v,int x)
{
edge[en].to=v;
edge[en].next=head[u];
edge[en].dis=x;
head[u]=en++;
edge[en].to=u;
edge[en].next=head[v];
edge[en].dis=x;
head[v]=en++;
}
void spfa(int s,int o)
{
queue<int> q;
for(int i=1;i<=n;i++)
{
dis[o][i]=INF;
in[i]=false;
path[o][i]=-1;
}
dis[o][s]=0;
in[s]=true;
path[o][s]=s;
q.push(s);
while(!q.empty())
{
int tag=q.front();
in[tag]=false;
q.pop();
for(int i=head[tag];i!=-1;i=edge[i].next)
{
int j=edge[i].to;
if(dis[o][tag]+edge[i].dis<dis[o][j])
{
dis[o][j]=dis[o][tag]+edge[i].dis;
path[o][j]=tag;
if(!in[j])
{
q.push(j);
in[j]=true;
}
}
}
}
}
void dfs(int p,int blank)
{
if(path[0][p]==p)
printf("%d%s",p,blank==0?" ":"\n");
else
{
dfs(path[0][p],0);
printf("%d%s",p,blank==0?" ":"\n");
}
}
int main()
{
bool ok=0;
while(~scanf("%d%d%d",&n,&s,&e))
{
if(ok)printf("\n");
ok=1;
memset(head,-1,sizeof(head));en=0;
scanf("%d",&m);
for(int i=0;i<m;i++)
{
int u,v,d;
scanf("%d%d%d",&u,&v,&d);
add(u,v,d);
}
spfa(s,0);
spfa(e,1);
scanf("%d",&k);
int mins=dis[0][e];
int tag1=e,tag2=e;
int ID=-1;
for(int i=1;i<=k;i++)
{
int u,v,d;
scanf("%d%d%d",&u,&v,&d);
if(dis[0][u]<INF&&dis[1][v]<INF&&dis[0][u]+dis[1][v]+d<mins)
{
mins=dis[0][u]+dis[1][v]+d;
tag1=u,tag2=v;
ID=i;
}
if(dis[0][v]<INF&&dis[1][u]<INF&&dis[0][v]+dis[1][u]+d<mins)
{
mins=dis[0][v]+dis[1][u]+d;
tag1=v,tag2=u;
ID=i;
}
}
if(ID==-1)
dfs(e,1);
else
{
dfs(tag1,0);
//printf("%d %d ",tag1,tag2);
while(path[1][tag2]!=tag2)
{
printf("%d ",tag2);
tag2=path[1][tag2];
}
printf("%d\n",tag2);
}
if(ID==-1)
printf("Ticket Not Used\n");
else
printf("%d\n",tag1);
printf("%d\n",mins);
}
return 0;
}