UVA 1025 A Spy in the Metro

Description

Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After several thrilling events we nd her in the rst station of Algorithms City Metro, examining the time table. The Algorithms City Metro consists of a single line with trains running both ways, so its time table is not complicated. Maria has an appointment with a local spy at the last station of Algorithms City Metro. Maria knows that a powerful organization is after her. She also knows that while waiting at a station, she is at great risk of being caught. To hide in a running train is much safer, so she decides to stay in running trains as much as possible, even if this means traveling backward and forward. Maria needs to know a schedule with minimal waiting time at the stations that gets her to the last station in time for her appointment. You must write a program that nds the total waiting time in a best schedule for Maria. The Algorithms City Metro system has N stations, consecutively numbered from 1 to N. Trains move in both directions: from the rst station to the last station and from the last station back to the rst station. The time required for a train to travel between two consecutive stations is xed since all trains move at the same speed. Trains make a very short stop at each station, which you can ignore for simplicity. Since she is a very fast agent, Maria can always change trains at a station even if the trains involved stop in that station at the same time.

Input

The input le contains several test cases. Each test case consists of seven lines with information as follows. Line 1. The integer N (2 ≤ N ≤ 50), which is the number of stations. Line 2. The integer T (0 ≤ T ≤ 200), which is the time of the appointment. Line 3. N 1 integers: t1,t2,...,tN1 (1 ≤ ti ≤ 20), representing the travel times for the trains between two consecutive stations: t1 represents the travel time between the rst two stations, t2 the time between the second and the third station, and so on. Line 4. The integer M1 (1 ≤ M1 ≤ 50), representing the number of trains departing from the rst station. Line 5. M1 integers: d1,d2,...,dM1 (0 ≤ di ≤ 250 and di < di+1), representing the times at which trains depart from the rst station. Line 6. The integer M2 (1 ≤ M2 ≤ 50), representing the number of trains departing from the N-th station. Line 7. M2 integers: e1,e2,...,eM2 (0 ≤ ei ≤ 250 and ei < ei+1) representing the times at which trains depart from the N-th station.

The last case is followed by a line containing a single zero.

Output

For each test case, print a line containing the case number (starting with 1) and an integer representing the total waiting time in the stations for a best schedule, or the word ‘impossible’ in case Maria is unable to make the appointment. Use the format of the sample output.

Sample Input

4

55

5 10 15

4

0 5 10 20

4

0 5 10 15

4

18

1 2 3

5

0 3 6 10 12

6 0 3 5 7 12 15

2

30

20

1

20

7 1 3 5 7 11 13 17

0

Sample Output

Case Number 1: 5

Case Number 2: 0

Case Number 3: impossible

题意:一个间谍要从第一个车站到第n个车站去会见另一个,在是期间有n个车站,有来回的车站,让你在时间T内时到达n,并且等车时间最短,输出最短等车时间。

思路:

先用一个has_train[t][i][0]来表示在t时刻,在车站i,是否有往右开的车。同理,has_train[t][i][1]用来保存是否有往左开的车。

         用d(i,j)表示时刻i,你在车站j,最少还需要等待多长时间。边界条件是d(T,n)=0,其他d(T,i)为正无穷。

         每次有三种决策:

         ①:等一分钟。

         ②:搭成往右开的车(如果有)。

         ③:搭成往左开的车(如果有)。

 

#include<stdio.h>
#include<string.h>
#include <algorithm>
#include <iostream>
#include<string>
using namespace std;

const int INF = 0x3f3f3f3f;
int T, n, dp[205][55], has_train[255][255][2], t[75], m1 ,m2;

int main()
{
    int cas = 0;
    while(~scanf("%d", &n)) {
        if (!n)
            break;
        scanf("%d", &T);
        for (int i = 1; i < n; i++) {
            scanf("%d", t + i);
        }
        memset(has_train, 0, sizeof(has_train));
        int x;
        scanf("%d", &m1);
        for (int i = 0; i < m1; i++) {
            scanf("%d", &x);
            for (int j = 1; x <= T && j <= n; j++) {
                has_train[x][j][0] = 1;
                x += t[j];
            }
        }
        scanf("%d", &m2);
        for (int i = 0; i < m2; i++) {
            scanf("%d", &x);
            for (int j = n; x <= T && j > 1; j--) {
                has_train[x][j][1] = 1;
                x += t[j - 1];
            }
        }

        for (int i = 1; i <= n - 1; i++)
            dp[T][i] = INF;
        dp[T][n] = 0;
        for (int i = T - 1; i >= 0; i--) {
            for (int j = 1; j <= n; j++) {
                dp[i][j] = dp[i + 1][j] + 1;    
                if (j < n && has_train[i][j][0] && i + t[j] <= T)
                    dp[i][j] = min(dp[i][j], dp[i + t[j]][j + 1]);  
                if (j > 1 && has_train[i][j][1] && i + t[j - 1] <= T)
                    dp[i][j] = min(dp[i][j], dp[i + t[j - 1]][j - 1]); 
            }
        }
        cout << "Case Number " << ++cas << ": ";
        if (dp[0][1] >= INF) cout << "impossible" << endl;
        else cout << dp[0][1] << endl;

    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值