CSUOJ 1010 Water Drinking

Description

The Happy Desert is full of sands. There is only a kind of animal called camel living on the Happy Desert. Cause they live here, they need water here. Fortunately, they find a pond which is full of water in the east corner of the desert. Though small, but enough. However, they still need to stand in lines to drink the water in the pond.

Now we mark the pond with number 0, and each of the camels with a specific number, starting from 1. And we use a pair of number to show the two adjacent camels, in which the former number is closer to the pond. There may be more than one lines starting from the pond and ending in a certain camel, but each line is always straight and has no forks.

Input

There’re multiple test cases. In each case, there is a number N (1≤N≤100000) followed by N lines of number pairs presenting the proximate two camels. There are 99999 camels at most.

Output

For each test case, output the camel’s number who is standing in the last position of its line but is closest to the pond. If there are more than one answer, output the one with the minimal number.

Sample Input

1
0 1
5
0 2
0 1
1 4
2 3
3 5
5
1 3
0 2
0 1
0 4
4 5

Sample Output

1
4
2

Hint

 

思路:两个数组,一个指向头,另一个维护后面数字的指向

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
#define MAXN 100000
int nex[MAXN],h[MAXN];
int main()
{
	int t;
	int n, m;
	while (~scanf("%d", &t))
	{
		int cnt = 0;
		int flag = 1;
		memset(nex, -1, sizeof(nex));
		memset(h, 0, sizeof(h));
		for (int i = 0; i < t; i++)
		{
			scanf("%d%d", &n, &m);
			if (n == 0)
				h[cnt++] = m;//当n为0时表示出现另一队,头+1
			else nex[n] = m;//否则n的后面为m
		}
		int ans = t;
		while (flag)
		{
			for (int i = 0; i < cnt; i++)//每次每队往后移一位
			{
				if (nex[h[i]] == -1)
				{
					ans = min(ans, h[i]);//当下一个为-1时表示这队已经到末尾了
					flag = 0;
				}
				h[i] = nex[h[i]];//移动头指针
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}
/**********************************************************************
	Problem: 1010
	User: leo6033
	Language: C++
	Result: AC
	Time:52 ms
	Memory:2804 kb
**********************************************************************/

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值