HDU 2141 Can you find it?

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

Output
For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.

Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10

Sample Output
Case 1:
NO
YES
NO

题意为,给出多个a,b,c的值和x的值,判断是否有一组a,b,c的和等于x

大致思路为,三重循环超时,用空间换时间,将a+b+c=x换做(a+b)+c=x,也就是a+b=x-c。先求出每一种a+b的和的可能性存入数组,并排序。二分的上下界为数组下标,0到总共可能性的个数。二分来查找是否存在a+b等于x-c的值。对于每个x,遍历每一个c值,看是否存在一个c,使得a+b=x-c。如果没有,则输出no,否则输出yes。

遇到的问题,在最后判断输出no时。应当在遍历每一个c都不符合后,判断应当为if(i>=m)。

代码如下:

#include<stdio.h>
#include<iostream>
#include<cstring>
#include<string.h>
#include<cmath>
#include<algorithm>
using namespace std;
int sum[250009],a[509],b[509],c[509],l,n,m,s,x;
bool bi_search(int rst){
    int le=0,ri=l*n-1;
    while(le<=ri){
        int mid=(le+ri)/2;
        if(sum[mid]==rst)
            return true;
        else if(sum[mid]>rst)
            ri=mid-1;
        else
            le=mid+1;
    }
    return false;
}
int main(){
    int cnt =1;
    while(~scanf("%d%d%d",&l,&n,&m)){
        int cn=0; //cn记录sum数组里的个数,cnt记录case数
        for(int i=0;i<l;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<n;i++)
            scanf("%d",&b[i]);
        for(int i=0;i<m;i++)
            scanf("%d",&c[i]);
        for(int i=0;i<l;i++)
            for(int j=0;j<n;j++)
                sum[cn++]=a[i]+b[j];
        sort(sum,sum+cn);
        scanf("%d",&s);
        printf("Case %d:\n",cnt++);
        while(s--){
            scanf("%d",&x);
            int i;
            for(i=0;i<m;i++){
                if(bi_search(x-c[i])){
                    puts("YES");
                    break;
                }
            }
            if(i>=m)
                puts("NO");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值