UVA 10382 Watering Grass (贪心)

原题:

      nsprinklers are installed in a horizontal strip of grassl meters long andw meters wide. Each sprinkler
is installed at the horizontal center line of the strip. For each sprinkler we are given its position as the
distance from the left end of the center line and its radius of operation.
What is the minimum number of sprinklers to turn on in order to water the entire strip of grass?
Input
Input consists of a number of cases. The first line for each case contains integer numbersn,l andw
with n 10000. The nextn lines contain two integers giving the position of a sprinkler and its radius
of operation. (The picture above illustrates the first case from the sample input.)
Output
For each test case output the minimum number of sprinklers needed to water the entire strip of grass.
If it is impossible to water the entire strip output ‘-1’.
Sample Input
8 20 2
5 3
4 1
1 2
7 2
10 2
13 3
16 2
19 4
3 10 1
3 5
9 3
6 1
3 10 1
5 3
1 1
9 1
Sample Output
62
-1



思路:

      将圆的覆盖范围转化成长度端点,遍历一边即可,判断是否有间隙或无法达到最右端。注意sqrt时的精度处理和圆直径小于等于宽时无法覆盖。


#include <iostream>
#include <iomanip>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <deque>
#include <string>
#include <cmath>
#include <vector>
#include <utility>
#include <set>
#include <map>
#include <sstream>
#include <climits>
//#pragma comment(linker, "/STACK:1024000000,1024000000")
#define pi acos(-1.0)
#define INF 2147483647
using namespace std;
typedef long long ll;
typedef pair <int,int > PP;
int N;
struct length
{
    double le,ri;
}len[10050];
bool cmp(const length&a,const length &b)
{
       return a.le<b.le;
}
int main()
{
    int n;
    double l,w;
    while(scanf("%d%lf%lf",&n,&l,&w)!=EOF)
    {
        for(int i=0;i<=10000;i++)
        {
            len[i].le=0;
            len[i].ri=0;
        }
        for(int i=0;i<n;i++)
        {
            double o,r,dis;
            scanf("%lf%lf",&o,&r);
            r=r*2;
            if(r<=w)
                dis=0;
            else
                dis=sqrt(r*r-w*w+0.5)/2;
            //printf("%lf\n",dis);
            len[i].le=o-dis;
            len[i].ri=o+dis;
        }
        sort(len,len+n,cmp);
//        for(int i=0;i<n;i++)
//           cout<<len[i].le<<" "<<len[i].ri<<endl;
        int res=0,j=0;
        bool no=false;
        for(double i=0.0;i<=l;)
        {
            double max_=-1;
            for(;len[j].le<=i&&j<n;j++)
            {
                if(max_<len[j].ri)
                    max_=len[j].ri;
            }
           // cout<<j<<endl;
            if(max_==-1)
            {
                no=true;
                break;
            }
            res++;
            i=max_;
            //cout<<i<<" "<<max_<<endl;
        }
        if(no)
            printf("-1\n");
        else
            printf("%d\n",res);
    }
    return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值