UVA10382 Watering Grass 贪心

题意是用最少的圆覆盖一个矩形区域,其实一个园相当于一个区间。然后就是用最少的小区间覆盖大区间的问题。贪心搞之。。。。

在一个小问题上纠结了好久,不应该。居然直接拿x-r了。。高中几何全部丢给老师了

 

Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu

[Submit]   [Go Back]   [Status]  

Description

Download as PDF

Problem E
Watering Grass
Input:
 standard input
Output: standard output
Time Limit: 3 seconds

n sprinklers are installed in a horizontal strip of grass l meters long and w meters wide. Each sprinkler is installed at the horizontal center line of the strip. For each sprinkler we are given its position as the distance from the left end of the center line and its radius of operation.

What is the minimum number of sprinklers to turn on in order to water the entire strip of grass?

Input

Input consists of a number of cases. The first line for each case contains integer numbers nl and w with n <= 10000. The next n lines contain two integers giving the position of a sprinkler and its radius of operation. (The picture above illustrates the first case from the sample input.)

 

Output

For each test case output the minimum number of sprinklers needed to water the entire strip of grass. If it is impossible to water the entire strip output -1.

Sample input

8 20 2

5 3

4 1

1 2

7 2

10 2

13 3

16 2

19 4

3 10 1

3 5

9 3

6 1

3 10 1

5 3

1 1

9 1

 

Sample Output

6

2

-1

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<cmath>

using namespace std;

#define eps 1e-8

int n,ct;
double l,w;

struct p
{
    double l,r;
}a[11000];

int sig(double k)
{
    if(fabs(k)<eps)
        return 0;
    return k>0?1:-1;
}

bool cmp(p a,p b)
{
    return sig(a.l-b.l)<0;
}

void greedy()
{
    sort(a,a+ct,cmp);
    double ll,rr;
    int ans;
    ll=rr=0,ans=0;
    for(int i=0;i<ct;i++)
    {
        if(sig(a[i].l-ll)>0)
        {
            ans++,ll=rr;
            if(sig(ll-a[i].l)<0)
                break;
            rr=max(a[i].r,rr);
        }
        else
            rr=max(a[i].r,rr);
    }
    if(sig(l-rr)<=0) printf("%d\n",ans);
    else printf("-1\n");
}

int main()
{
    while(~scanf("%d%lf%lf",&n,&l,&w))
    {
        double x,r;
        ct=0;
        for(int i=0;i<n;i++)
        {
            scanf("%lf%lf",&x,&r);
            if(sig(r*2-w)<0) continue;
            double dis;
            dis=sqrt(r*r-w*w/4);
            a[ct].l=x-dis;
            a[ct++].r=x+dis;
        }
        a[ct].l=0X7FFFFFFF;
        a[ct++].r=0X7FFFFFFF;
        greedy();
    }
    return 0;
}



 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值