笨小熊
时间限制:2000 ms | 内存限制:65535 KB
难度:2
题目链接:http://acm.nyist.edu.cn/JudgeOnline/problem.php?pid=62
描述
笨小熊的词汇量很小,所以每次做英语选择题的时候都很头疼。但是他找到了一种方法,经试验证明,用这种方法去选择选项的时候选对的几率非常大!
这种方法的具体描述如下:假设maxn是单词中出现次数最多的字母的出现次数,minn是单词中出现次数最少的字母的出现次数,如果maxn-minn是一个质数,那么笨小熊就认为这是个Lucky Word,这样的单词很可能就是正确的答案。
输入
第一行数据N(0<N<100)表示测试数据组数。
每组测试数据输入只有一行,是一个单词,其中只可能出现小写字母,并且长度小于100。
输出
每组测试数据输出共两行,第一行是一个字符串,假设输入的的单词是Lucky Word,那么输出“Lucky Word”,否则输出“No Answer”;
第二行是一个整数,如果输入单词是Lucky Word,输出maxn-minn的值,否则输出0
样例输入
2
error
olympic
样例输出
Lucky Word
2
No Answer
0
解题思路:
先对给定的字符串进行排序 然后用数组统计各个字母分别有几个,再把数组从大到小排序后 判断是否为质数即可。
代码如下:
#include<iostream>
#include<cmath>
#include<string>
#include<cstdio>
#include<algorithm>
using namespace std;
bool cmp(int a,int b)
{
return a>b;
}
int PD(int a)
{
//0和1不是质数
if(a==0||a==1) return 0;
for(int i=2;i<a;i++)
if(a%i==0) return 0;
return 1;
}
int main()
{
int N;
cin >> N;
while(N--)
{
string str;
int num[101]={0},j=0;
cin >> str;
getchar();
sort(str.begin(),str.end());
//cout << str <<endl;
for(int i=0;i<str.size();i++)
{
if(i<str.size()-1)
if(str.at(i)==str.at(i+1))
{
num[j]++;
//cout << "num[" << j << "]\t"<< num[j] << endl;
}
else
{
num[j]++;
//cout << "num[" << j << "]\t"<< num[j] << endl;
j++;
}
else
if(str.at(i)==*(str.end()-1))
{
num[j]++;
//cout << "num[" << j << "]\t"<< num[j] << endl;
}
else
{
num[j]++;
//cout << "num[" << j << "]\t"<< num[j] << endl;
j++;
}
}
sort(num,num+101,cmp);
// //cout << num[3] <<endl <<endl;
// for(int i=0;i<j;i++)
// {
// cout << num[i] << endl;
// }
// cout << num[j]-num[0] << endl;
if(PD(num[0]-num[j]))
{
//cout << j << endl;
cout << "Lucky Word\n" << (num[0]-num[j]) << endl;
}
else
{
//cout << j-1 << endl;
cout << "No Answer\n0\n";
}
}
return 0;
}