【动态规划】POJ 1163 The Triangle

The Triangle(简单dp)

点我访问题目链接

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 60250 Accepted: 36099

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

Source

IOI 1994

题目大意:

给定一个三角形,规定从第一行第一列的数字开始往下走(每次只能走下方或者右下方),然后每走一次,值相加,求到最后一行的距离最大值。

解题思路:

记录再利用的dp,从上往下遍历,每次到达一个值,就更改此值为该值+直上与该值+右上的最大值。核心代码:

dp[i][j]=max(dp[i][j]+dp[i-1][j],dp[i][j]+dp[i-1][j-1]);

AC代码:

//The Triangle
#include<iostream>
#define MAXN 105
using namespace std;

int dp[MAXN][MAXN];
int n;
int maxn=-1;
void solve()
{
	for(int i=1;i<=n;i++)
		for(int j=1;j<=i;j++)
		{
			dp[i][j]=max(dp[i][j]+dp[i-1][j],dp[i][j]+dp[i-1][j-1]);
			maxn=max(maxn,dp[i][j]);
		}
			
	cout << maxn << endl;
}

int main()
{
	cin >> n;
	for(int i=1;i<=n;i++)
		for(int j=1;j<=i;j++)
			cin >> dp[i][j];
	solve();
	return 0;
}

 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值