二维SPFA: As Long As Binbin Loves Sangsang

As long as Binbin loves Sangsang

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 753    Accepted Submission(s): 195


Problem Description
Binbin misses Sangsang so much. He wants to meet with Sangsang as soon as possible.
Now Binbin downloads a map from ELGOOG.There are N (1<=N<=1,314) cities in the map and these cities are connected by M(0<=M<=13,520) bi-direct roads. Each road has a length L (1<=L<=1,314,520)and is marked using a unique ID, which is a letter fromthe string “LOVE”!
Binbin rides a DONKEY, the donkey is so strange that it has to walk in the following sequence ‘L’->’O’->’V’->’E’->’L’->’O’->’V’->’E’->.... etc.
Can you tell Binbin how far the donkey has to walk in order to meet with Sangsang?
WARNING: Sangsang will feel unhappy if Binbin ride the donkey without a complete”LOVE” string.
Binbin is at node 1 and Sangsang is at node N.
 

Input
The first line has an integer T(1<=T<=520), indicate how many test cases bellow.
Each test case begins with two integers N, M (N cities marked using an integer from 1…N and M roads).
Then following M lines, each line has four variables“U V L letter”, means that there is a road between city U,V(1<=U,V<=N) with length L and the letter marked is‘L’,’O’,’V’ or ‘E’
 

Output
For each test case, output a string
1.  “Case ?: Binbin you disappoint Sangsang again, damn it!”
If Binbin failed to meet with Sangsang or the donkey can’t finish a path withthe full “LOVE” string.
2.  “Case ?: Cute Sangsang, Binbin will come with a donkey after travelling ? meters and finding ? LOVE strings at last.”
Of cause, the travel distance should be as short as possible, and at the same time the “LOVE” string should be as long as possible.
 

Sample Input
  
  
2 4 4 1 2 1 L 2 1 1 O 1 3 1 V 3 4 1 E 4 4 1 2 1 L 2 3 1 O 3 4 1 V 4 1 1 E
 

Sample Output
  
  
Case 1: Cute Sangsang, Binbin will come with a donkey after travelling 4 meters and finding 1 LOVE strings at last. Case 2: Binbin you disappoint Sangsang again, damn it!
 

Author
FZU
 

Source


跟普通的SPFA 不同的是,这个题得用二维的,把每个点拆成四种状态进行

路程变短的情况优先考虑

如果路程不变则到该点为止LOVE数不能减少,否则不考虑

另外得注意有自环的trick


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>

using namespace std;

#define MAXN 9400
#define MAXM 90000
#define INF 1LL<<63-1

struct Edge{
    int v;
    int next;
    long long w;
    int id;
}edge[MAXM];

struct Point{
    int id;
    int u;
    Point(){}
    Point(int a, int b){
        u = a;
        id = b;
    }
};

int e, n, m, lastshow[MAXN];

void insert(int x, int y, long long w, char c){
    edge[e].v = y;
    edge[e].w = w;
    edge[e].next = lastshow[x];
    if(c == 'L')
        edge[e].id = 0;
    else if(c == 'O')
        edge[e].id = 1;
    else if(c == 'V')
        edge[e].id = 2;
    else if(c == 'E')
        edge[e].id = 3;
    lastshow[x] = e ++;
}

long long d[MAXN][4];
int vis[MAXN][4], num[MAXN][4];
queue<Point>q;

void init(){
    while(!q.empty()){
        q.pop();
    }
    e = 0;
    memset(lastshow, -1, sizeof(lastshow));
}

void spfa(int src){
    for(int i = 1; i <= n; i ++){
        for(int j = 0; j < 4; j ++){
            d[i][j] = INF;
            vis[i][j] = 0;
            num[i][j] = 0;//因为每个点都存在四种状态,距离和vis都变成二维的
        }
    }
    vis[src][3] = 1;
    d[src][3] = 0;
    Point tmp = Point(src, 3);//一个点的id是通向它的那条边的id
    q.push(tmp);
    while(!q.empty()){
        tmp = q.front();
        q.pop();
        int u = tmp.u;
        int id = tmp.id;
        vis[u][id] = 0;
        for(int i = lastshow[u]; i != -1; i = edge[i].next){//检查相连的每条边
            int v = edge[i].v;
            int x = edge[i].id;
            long long w = edge[i].w;
            if((d[u][id] + w <= d[v][x] || d[v][x] == 0) && (id + 1) % 4 == x){//如果路程能不变或变短且能接下去
                if(num[v][x] > num[u][id] && d[u][id] + w == d[v][x])           //||d==0是为了自环时的判断
                    continue;//特别注意的是如果路程不变则num不能变少
                d[v][x] = d[u][id] + w;
                num[v][x] = num[u][id];
                if(x == 3)
                    num[v][x] ++;//每走完一个完整的LOVE,num相应的加一
                if(!vis[v][x]){
                    q.push(Point(v, x));
                    vis[v][x] = 1;
                }
            }
        }
    }
}

char s[10];

int main(){
    int t, cas =0;
    scanf("%d", &t);
    while(t --){
        init();
        scanf("%d %d", &n, &m);
        int u, v, w;
        while(m --){
            scanf("%d %d %d %s", &u, &v, &w, s);
            insert(u, v, w, s[0]);
            insert(v, u, w, s[0]);
        }
        spfa(1);
        if(num[n][3] == 0 || d[n][3] == INF)
            printf("Case %d: Binbin you disappoint Sangsang again, damn it!\n", ++cas);
        else
            printf("Case %d: Cute Sangsang, Binbin will come with a donkey after travelling %I64d meters and finding %d LOVE strings at last.\n", ++cas, d[n][3], num[n][3]);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值