[hungary][最小顶点覆盖][二分图]hdu 1054

听说此题很经典,有三种解法
这里三种解法讲的都很好


在此,写出二分图的最大匹配方法

Strategic Game

            Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
           Total Submission(s): 5313    Accepted Submission(s): 2452

Problem Description
Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 … node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree:

the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:

Sample Input
4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output
1
2

Source
Southeastern Europe 2000

//最小顶点覆盖问题
//然而一直超时
//于是用vector
//然后就不超时了kao
#include<iostream>
#include<cstdio>
#include<ctime>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<string>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<algorithm>
#ifdef WIN32
#define AUTO "%I64d"
#else
#define AUTO "%lld"
#endif
#define INF 0x3f3f3f3f
#define clock CLOCKS_PER_SEC
#define cle(x) memset(x,0,sizeof(x))
#define maxcle(x) memset(x,0x3f,sizeof(x))
#define mincle(x) memset(x,-1,sizeof(x))
#define maxx(x1,x2,x3) max(x1,max(x2,x3))
#define minn(x1,x2,x3) min(x1,min(x2,x3))
#define cop(a,x) memcpy(x,a,sizeof(a))
#define FROP "hdu"
#define C(a,b) next_permutation(a,b)
#define LL long long
#define smin(x,tmp) x=min(x,tmp)
#define smax(x,tmp) x=max(x,tmp)
using namespace std;
const int N = 1505;
vector<int>G[N];
int vis[N],head[N],match[N];
bool crosspath(int u)
{
    for(int i = 0;i<G[u].size() ; i++)
    {
        int v=G[u][i];
        if(!vis[v])
        {
            vis[v]=1;
            if(match[v]==-1||crosspath(match[v]))
            {
                match[v]=u;
                return true;
            }
        }
    }
    return false;
}
int n,tot;
int hungary()
{
    int ans=0;
    for(int i = 0;i <= n-1; i++)
    {
        cle(vis);
        if(crosspath(i))ans++;
    }
    return ans/2;
}
int main()
{
    freopen(FROP".in","r",stdin);
    freopen(FROP".out","w",stdout);
    while(scanf("%d",&n)==1)
    {
        int tot=0;
        cle(match);
        for(int i = 1; i <= n; i++)
        {
            int x;
            scanf("%d",&x);
            getchar();getchar();
            int w;
            scanf("%d",&w);
            getchar();
            for(int j= 1; j <= w; j++)
            {
                int y;
                scanf("%d",&y);
                G[x].push_back(y);
                G[y].push_back(x);
            }
        }
        mincle(match);
        printf("%d\n",hungary());
        for(int i = 0; i< n; i++)
        G[i].clear();
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值