容斥原理练习 hdoj1796&&nyoj644

基础:需要对公式有深刻认识,要理解每一项前面的符号以及每一项的意义。
处理方案:一般此题使用dfs对容斥公式进行求解。

Problem Description
Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

Input
There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

Output
For each case, output the number.

Sample Input
  
  
12 2 2 3

Sample Output
  
  
7


#include<iostream>
#include<cstdio>
using namespace std;
__int64 n;
__int64 d[21];
__int64 ans;

__int64 gcd(long a,long b)
{
    return b==0 ? a : gcd(b,a%b);
}
__int64 LCM(long a,long b)//计算最小公倍数
{
    return (a*b)/gcd(a,b);
}

void dfs(int deep,int a,__int64 lcm,int m)
{
    if(deep > m)//当递归到层数大于集合总数时
    {
        if(a == 0)//从容斥公式中指数为1时开始计算,其中指数为1时为所有集合之和
            return;
        if(a%2==1)
            ans += n/lcm;
        else
            ans -= n/lcm;
        //cout<<ans<<endl;
        return;
    }
    dfs(deep+1,a,lcm,m);
    dfs(deep+1,a+1,LCM(d[deep],lcm),m);
}
int main()
{
    int m;
    int i;
    while(~scanf("%d%d",&n,&m))
    {
        ans = 0;
        n--;
        for(i = 1; i <= m; i++)
        {
            int t;
            scanf("%d",&t);
            if(t==0)
            {
                i--;
                m--;
                continue;
            }
            else
                d[i] = t;
        }
        dfs(1,0,1,m);
        printf("%I64d\n",ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值