HDU1796-How many integers can you find

How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3867    Accepted Submission(s): 1088


Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 

Output
  For each case, output the number.
 

Sample Input
  
  
12 2 2 3
 

Sample Output
  
  
7
 
题意:问在1~n-1这几个数,能被一个集合中的某个数整除的数的个数。

思路:容斥即可解决。‘
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
typedef long long ll;
int n,m;
vector<int> num;
int gcd(int a,int b){
    if(b==0) return a;
    return gcd(b,a%b);
}
int Lcm(int a,int b){
    return a/gcd(a,b)*b;
}
void solve(){
    vector<int> dig;
    int ans = 0;
    for(int i = 1; i < (1<<m); i++){
        dig.clear();
        for(int j = 0; j < m; j++){
            if(i & (1<<j)) dig.push_back(j);
        }
        int t = 1;
        for(int j = 0; j < dig.size(); j++){
            t = Lcm(t,num[dig[j]]);
        }
        if(dig.size()%2==0) ans -= n/t;
        else ans += n/t;
    }
    cout<<ans<<endl;
}
int main(){

    while(~scanf("%d%d",&n,&m)){
        n--;
        num.clear();
        int tn;
        for(int i = 0; i < m; i++){
            scanf("%d",&tn);
            if(tn!=0) num.push_back(tn);
        }
        m = num.size();
        solve();

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值