POJ——2478 Farey Sequence(欧拉函数)

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

题意:看那些式子也知道了,就是求1-n中有多少对互质的数,即phi[1]+phi[2]+......+phi[n]

题解:预处理出phi,然后求一个前缀和,就完事了~~

预处理主要用到了欧拉函数的性质2和性质3

欧拉函数的三个性质

性质1: 当q为质数时phi(q)=q-1

性质2: 如果i/p是p的倍数时phi(i)=phi(i/p)*p      这里p是最小质因子

性质3: 如果i/p不是p的倍数时phi(i)=phi(i/p)*(p-1)    这里p是最小质因子

性质2,性质3的用法,具体看代码:

上代码:

#include <iostream>
#include <cstdio>
using namespace std;
typedef long long ll;
const int MAX = 1e6+520;
ll a[MAX],p[MAX],phi[MAX],sum[MAX];
bool vis[MAX];
int cnt;
void init(){
	vis[1]=vis[0]=1;
	for (int i = 2; i < MAX;i++){
		if(!vis[i]){
			p[cnt++]=i;
			a[i]=i;//a数组存的是最小质因子
		}
		for (int j = 0; j < cnt&&i*p[j] < MAX;j++){
			vis[i*p[j]]=1;
			a[i*p[j]]=p[j];
			if(i%p[j]==0) break;
		}
	}
}
void getphi(){
	phi[1]=1;
	for (int i = 2; i < MAX;i++){
		if(a[i/a[i]]==a[i]) phi[i]=phi[i/a[i]]*a[i];//性质2
		else phi[i]=phi[i/a[i]]*(a[i]-1);//性质3
	}
}
int main(){
	init();
	getphi();
	for (int i = 2; i < MAX;i++) sum[i]=sum[i-1]+phi[i];
	int n;
	while(scanf("%d",&n)&&n) printf("%lld\n",sum[n]);
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

心脏dance

如果解决了您的疑惑,谢谢打赏呦

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值