Farey Sequence POJ - 2478(欧拉函数)

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}

You task is to calculate the number of terms in the Farey sequence Fn.
Input
There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.
Output
For each test case, you should output one line, which contains N(n) —- the number of terms in the Farey sequence Fn.
Sample Input
2
3
4
5
0
Sample Output
1
3
5
9

/*
    欧拉函数的简单应用,欧拉函数是求出1 到 n 中与n互质的数的个数 
    打表求出欧拉函数
    euler[n] = n * ( 1 - 1/p1) * (1 - 1/p2) * (1 - 1/p3)....  p1,p2,...是 n 的素因子 
*/
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<queue>
#include<algorithm>

#define ll long long
#define inf 0x3f3f3f3f
#define maxn 1000007  // 1e6+7

using namespace std;

long long euler[maxn];
long long num[maxn];


void init()
{
    euler[1] = 1;
    for(int i=2;i<maxn;i++)
        euler[i] = i;
    for(int i=2;i<maxn;i++)
    {
        if(euler[i] == i)
            for(int j=i;j<maxn;j+=i)
                euler[j] = euler[j] / i * (i-1);  // euler[j] = euler[j] * ( 1 - 1 / i); i 为 j 的素因子 
    }

}
int main()
{
    init();
    num[1] = 0;
    for(int i=2;i<maxn;i++)
        num[i] = (num[i-1] + euler[i]);

    int n;
    while(~scanf("%d",&n),n)
    {
    //  printf("%d\n",euler[n]);
        printf("%lld\n",num[n]);
    } 
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值