poj1595Prime Cuts


题意:
给你一个数,n,c,你要做的就是将1到n之间的素数按照顺序(升序)全部找出来(本题中1也是素数)
1.如果你找出来的素数的总个数(count)是奇数,就输出这一串素数中最中间的2*c-1个素数。如果素数总个数小于等于2*c-1,就将你找到的素数按照升序全部输出;如果素数总个数大于2*c-1,就输出这一串素数中最中间的2*c-1个素数。
(例如:一串素数为1,2,3,5,7,11,13;共7个,假如你需要输出的是3个的话,就得从3开始输出,输出的一串数为:3,7,11.)
2.若你找出来的素数总个数是偶数,就输出这一串素数中最中间的2*c个素数。其它执行与第1种情况相同,就是偶数时执行的是2*c。
Prime Cuts
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 10395Accepted: 3976

Description

A prime number is a counting number (1, 2, 3, ...) that is evenly divisible only by 1 and itself. In this problem you are to write a program that will cut some number of prime numbers from the list of prime numbers between (and including) 1 and N. Your program will read in a number N; determine the list of prime numbers between 1 and N; and print the C*2 prime numbers from the center of the list if there are an even number of prime numbers or (C*2)-1 prime numbers from the center of the list if there are an odd number of prime numbers in the list.

Input

Each input set will be on a line by itself and will consist of 2 numbers. The first number (1 <= N <= 1000) is the maximum number in the complete list of prime numbers between 1 and N. The second number (1 <= C <= N) defines the C*2 prime numbers to be printed from the center of the list if the length of the list is even; or the (C*2)-1 numbers to be printed from the center of the list if the length of the list is odd.

Output

For each input set, you should print the number N beginning in column 1 followed by a space, then by the number C, then by a colon (:), and then by the center numbers from the list of prime numbers as defined above. If the size of the center list exceeds the limits of the list of prime numbers between 1 and N, the list of prime numbers between 1 and N (inclusive) should be printed. Each number from the center of the list should be preceded by exactly one blank. Each line of output should be followed by a blank line. Hence, your output should follow the exact format shown in the sample output.

Sample Input

21 2
18 2
18 18
100 7
Sample Output
21 2: 5 7 11

18 2: 3 5 7 11

18 18: 1 2 3 5 7 11 13 17

100 7: 13 17 19 23 29 31 37 41 43 47 53 59 61 67
 
#include<stdio.h>
#include<string.h>
#define M 10000
int prime[M];
int a[M];
int main()
{
	int i,j;
	memset(prime,0,sizeof(prime));
	prime[0]=1;
	prime[1]=prime[2]=0;            //在本题中,1也被看做素数 
	
	for(i=2;i*i<=M;i++)           //先进行素数打表 
	{
		if(!prime[i])
		{
			for(j=2*i;j<=M;j+=i)
			prime[j]=1;
		}
	}
	
	int n,c,count,t;
	memset(a,0,sizeof(a)); 
	while(~scanf("%d%d",&n,&c))
	{
		count=0;
	    for(i=1,j=0;i<=n;i++)         //找出1到n之间素数的总数; 
		{
		    if(!prime[i])
		    {
		    	a[j++]=i;           //a[0]=1; 
		    	count++;       
		    }	 
		}
		printf("%d %d:",n,c);
		if(count&1)             //如果count为奇数,执行如下处理语句 
		{
			if(count<=2*c-1)
			{
				for(j=0;j<count;j++)
				printf(" %d",a[j]);
			}
			else
			{
				t=(count-(2*c-1))/2;
				for(j=t;j<t+2*c-1;j++)//因为数组a是从0开使的,所以执行时从t开始即可 
				printf(" %d",a[j]);
			}
		}
		else                         //count为偶数时执行如下处理语句 
		{
			if(count<=2*c)
			{
				for(j=0;j<count;j++)
				printf(" %d",a[j]);
			}
			else
			{
				t=(count-2*c)/2;
				for(j=t;j<t+2*c;j++)
				printf(" %d",a[j]);
			}
		}
		printf("\n\n");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值