Picture hdoj 2052

Picture
Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16014    Accepted Submission(s): 8292




Problem Description
Give you the width and height of the rectangle,darw it.
 


Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
 


Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line. 
 


Sample Input
3 2
 


Sample Output
+---+
|      |
|      |
+---+
 


Author
xhd
 


Source
校庆杯Warm Up 



#include<cstdio>
#include<string.h>
#include<stdlib.h>
int main()
{
int n,m;
char a[100][100];
while(~scanf("%d%d",&n,&m))
{
int i,j;
     for(i=0;i<m+2;i++)
     {
      for(j=0;j<n+2;j++)
       {
        if(i==0||i==m+1) 
        {
        if(j==0||j==n+1) // a[0][0]=a[0][n+1]=a[m+1][n+1]='+';
        {
        a[i][j]='+';
        }
        else
         a[i][j]='-';  //a[0][j]=a[m+1][j]='-';
        }
        else
         if(j==0||j==n+1)
           a[i][j]='|';
           else
             a[i][j]=' ';
       }
     }
     
   for(i=0;i<m+2;i++)
     {
      for(j=0;j<n+2;j++)
       printf("%c",a[i][j]);
       printf("\n");
     } 
     printf("\n");
}
return 0;

}

虽然很水,但由于打印的比较美观,就给大家分享了一下O(∩_∩)O哈哈~

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值