LA4329 树形数组

Description

N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee’s house. For some reason, the contestants can’t choose a referee whose skill rank is higher or lower than both of theirs. The contestants have to walk to the referee’s house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case.
Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 … aN follow, indicating the skill rank of each player, in the order of west to east. (1 <= ai <= 100000, i = 1 … N).

Output

For each test case, output a single line contains an integer, the total number of different games.

Sample Input

1
3 1 2 3

Sample Output

1

题意:

一条大街上住着n个乒乓球爱好者,经常组织比赛。每个人都有一个技能值ai,每场比赛需要3个人:两名选手和一名裁判。规定裁判位置必须在两个选手的中间,而且技能值也必须在两个选手的中间,问一共能组织多少种比赛

思路:

考虑第i个人当裁判的情形,假设a1到a[i-1]中有ci个比ai小,那么就有(i-1)-ci个比ai大,同理,假设a[i+1]到an中有di个比ai小,那么就有(n-i)-di个比ai大,然后根据乘法原理和加法原理,i当裁判有ci(n-i-di)+(i-ci-1)*di,这样问题就转化为求c,d

#include <iostream>
#include <cstring>
using namespace std;
//a[]存储每个人的技能值
//c[]存储树形数组,初始值为0,代表不存在a[i]这个数,1代表存在a[i]这个数(当技能值存在时为1)
//s[]代表在a[]中,在0~i之中有多少数字大于a[i];
//d[]代表在a[]中,在i+1~n之中有多少数字大于a[i];
long long int a[20005],c[20005],d[20005],s[20005];
long long int max1;
long long int lowbit(long long int x)
{
    return x&-x;
}
long long int sum(long long int x)
{
   int ret=0;
   while(x>0)
   {
       ret+=c[x];
       x-=lowbit(x);
   }
   return ret;

}
void add(long long int x,int d1)
{
    while(x<=max1)
    {
        c[x]+=d1;
        x+=lowbit(x);
    }
}
int main()
{
    int n,t;
    max1=-1;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(int i=1;i<=n;i++)
        {
            cin>>a[i];
            max1=(max1>a[i])?max1:a[i];
        }

        //a[]存储了顺序
        //我们可以想象:在树形数组中:如果存在技能值,则A[i]的值为1,否则为0;c[x]表示在a[]中有多少个技能值在x前面;
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
        {
            //a[i]代表某个人的技能值
            //sum(a[i])代表前面有多少人技能大于a[i];
            //因为在树形数组中,若不存在某个人的技能值,那么为0,否则为1,所以只需要统计前缀和就行了
            s[i]=sum(a[i]);
            //存在技能值,在树形数组中将其值改为1
            add(a[i],1);
        }

        //a[]存储了顺序
        memset(c,0,sizeof(c));
        for(int i=n;i>=1;i--)
        {
            //a[i]代表某个人的技能值
            //sum(a[i])代表前面有多少人技能大于a[i];
            //因为在树形数组中,若不存在某个人的技能值,那么为0,否则为1,所以只需要统计前缀和就行了
            d[i]=sum(a[i]);
            //存在技能值,在树形数组中将其值改为1
            add(a[i],1);
        }

        long long int cnt=0;
        for(int i=1;i<=n;i++)
        {
            cnt+=(s[i]*(n-i-d[i])+(i-1-s[i])*d[i]);
        }
        cout<<cnt<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值