九度OJ 题目1464:Hello World for U

一.题目描述:
Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h    d
 e     l
 l      r
 lowo


 That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.
输入:
There are multiple test cases.Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.
输出:
For each test case, print the input string in the shape of U as specified in the description.

样例输入:

 helloworld!
ac.jobdu.com
样例输出:

 h   !
e   d
l   l
lowor
a    m
c    o
.    c
jobdu.

二.题目分析

  本题中算好n1,n2,n3的关系,n1=n3,n1+n2+n2-2=N,n2=(n+2)/3即可

三.代码

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define MAX 82
int main()
{
    char str[MAX];
    int n1,n2,len,i,j1,j2,k;

    while(scanf("%s",str)!=EOF)
    {
        len=strlen(str);
        n1=(len+2)/3;
        n2=len+2-2*n1;
        j1=0;
        j2=len-1;

        for(i=0;i<n1;i++)
        {
            if(i!=n1-1)
            {
                for(k=0;k<n2;k++)
                {
                    if(k==0)
                    {
                        printf("%c",str[j1]);
                        j1++;
                    }

                    else if(k==n2-1)
                    {
                        printf("%c\n",str[j2]);
                        j2--;
                    }

                    else
                        printf(" ");
                }
            }
            else
            {
                for(k=j1;k<=j2;k++)
                    printf("%c",str[k]);
                printf("\n");
            }
        }
    }



    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值