-
题目描述:
-
Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:
h d
e l
l r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.
-
输入:
-
There are multiple test cases.Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.
-
输出:
-
For each test case, print the input string in the shape of U as specified in the description.
-
样例输入:
-
helloworld! ac.jobdu.com
-
样例输出:
-
h ! e d l l lowor a m c o . c jobdu.
#include <cstdio>
#include <cstring>
#define MAXSIZE_STR 90
#define MAXSIZE_MATR 30
using namespace std;
int main(){
char str[MAXSIZE_STR];
char matr[MAXSIZE_MATR][MAXSIZE_MATR];
int n1,n2;//height,width
int len;
while (scanf("%s",str)!=EOF){
//initiate
len=strlen(str);
n1=(len+2)/3;
n2=len+2-2*(n1);
for (int i=0;i<n1;i++){
for (int j=0;j<n2;j++){
matr[i][j]=' ';
}
}
//paint
int p=0;
for (int i=0;i<n1;i++){
matr[i][0]=str[p];
p++;
}
for (int i=1;i<n2;i++){
matr[n1-1][i]=str[p];
p++;
}
for (int i=n1-2;i>=0;i--){//bug
matr[i][n2-1]=str[p];
p++;
}
//output
for (int i=0;i<n1;i++){
for (int j=0;j<n2;j++){
printf("%c",matr[i][j]);
}
printf("\n");
}
}
return true;
}