一.题目分析
题目描述:
To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.
Figure 1
You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).
输入:
For each case, the first line contains two addresses of nodes and a positive N (<= 10^5), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.
输出:
For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.
样例输入:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
样例输出:
67890
-1
二.题目分析
当出现重复位置时,第三列的数字一定会有重复数字,因此只用判重就行了,需要注意的是,头结点也需要开始时判重,考虑从头结点重复的情况。
三.代码
#include <stdio.h>
#include <stdlib.h>
#define MAX 100005
int main()
{
int s1,s2,a1,a2,i,N,same;
int b[MAX];
char ch;
freopen("1468.txt","r",stdin);
while(scanf("%d%d%d",&s1,&s2,&N)!=EOF)
{
same=-1;
for(i=0;i<MAX;i++)
b[i]=0;
b[s1]=1;
b[s2]=1;
if(s1==s2)
same=s1;
for(i=0;i<N;i++)
{
scanf("%d %c %d",&a1,&ch,&a2);
if(a2==-1)
continue;
else if(b[a2]==0)
b[a2]=1;
else
same=a2;
}
if(same!=-1)
printf("%05d\n",same);
else
printf("-1\n");
}
return 0;
}