poj3279:Fliptile

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input

Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

题目大意
有一个M*N的格子,每个格子一面是黑色,一面是白色,黑色的格子反转过去就是白色的,白色的格子反转过去就是黑色。每次翻转一个格子时,与它上下相邻的格子也会被翻转。要求将所有格子都翻转成白色。求最少翻转次数。

典型的开灯问题,和poj1222几乎完全相同。
代码如下:

#include<iostream>
#include<cstring>
using namespace std;
int dir[5][2]={-1,0,0,-1,0,0,0,1,1,0};//邻接格子的坐标 
int M,N;
int tile[20][20];//牛原始的方向 
int opt[20][20];//保存最优解 
int flip[20][20];//保存中间结果 
int get(int x,int y)//查询(x,y)的状态 
{
    int c=tile[x][y];
    for(int d=0;d<5;d++)
    {
        int x2=x+dir[d][0];
        int y2=y+dir[d][1];
        if(0<=x2&&x2<M&&0<=y2&&y2<N)
        c+=flip[x2][y2];
    }
    return c%2;
}
int calc()
{
    for(int i=1;i<M;i++)
    for(int j=0;j<N;j++)
    {
        if(get(i-1,j)!=0)
        flip[i][j]=1;
    }//求从第二行开始的翻转方法 

    for(int j=0;j<N;j++)
    if(get(M-1,j)!=0)
    return -1;//判断最后一行的状态 

    int res=0;
    for(int i=0;i<M;i++)
    for(int j=0;j<N;j++)
    res+=flip[i][j];
    return res;//统计翻转次数 
}
void solve()
{
    int res=-1;
    for(int i=0;i<1<<N;i++)
    {
        memset(flip,0,sizeof(flip));
        for(int j=0;j<N;j++)//按照字典序尝试第一行的所有可能性 
        flip[0][N-j-1]=i>>j&1;//i的二进制中,从右往左取j+1位上的值 
        int num=calc();
        if(num>=0&&(res<0||res>num))
        {
            res=num;
            memcpy(opt,flip,sizeof(flip));
        }
    }
    if(res<0)
    cout<<"IMPOSSIBLE"<<endl;
    else
    {
        for(int i=0;i<M;i++)
        {
        for(int j=0;j<N-1;j++)
        cout<<opt[i][j]<<" ";
        cout<<opt[i][N-1]<<endl;
        }

    }
}
int main()
{
    int i,j;
    while(cin>>M>>N)
    {
        for(i=0;i<M;i++)
        for(j=0;j<N;j++)
        cin>>tile[i][j];

        solve();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值