寒假训练01B:hdu1029

Problem Description
“OK, you are not too bad, em… But you can never pass the next test.” feng5166 says.

“I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers.” feng5166 says.

“But what is the characteristic of the special integer?” Ignatius asks.

“The integer will appear at least (N+1)/2 times. If you can’t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha…..” feng5166 says.

Can you find the special integer for Ignatius?

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.

Output
For each test case, you have to output only one line which contains the special number you have found.

Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1

Sample Output
3
5
1

题目大意
给你一个奇数项n的数列,输出其中出现次数大于等于(2+n)/2的这一项。

解题思路
最初的想法是使用一个数组,每次输入的一个数,以该数为下标的那一项加一。然后检测该项是否大于等于(2+n)/2。若满足则记录下来,待n个数输入完毕以后输出记录下来的数。这是O(n)的时间复杂度,但是大概系数略大,卡着线勉勉强强能过。在网上发现一种更机智的做法,对该序列排个序,那么在中间的那一项一定是我们要寻找的元素,这种做法时间复杂度可以降到O(logn)。唉,感觉自己还是不够机智。。。

代码

#include<iostream>
#include<memory.h>
using namespace std;
int a[999999];
int main()
{
    int n,num,ans,temp;
    while(cin>>n)
    {
        memset(a,0,sizeof(a));
        temp=(1+n)/2;
        while(n--)
        {

            cin>>num;
            a[num]++;
            if(a[num]>=temp)
            ans=num;
        }
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值