poj3140:Contestants Division

Problem Description
In the new ACM-ICPC Regional Contest, a special monitoring and submitting system will be set up, and students will be able to compete at their own universities. However there’s one problem. Due to the high cost of the new judging system, the organizing committee can only afford to set the system up such that there will be only one way to transfer information from one university to another without passing the same university twice. The contestants will be divided into two connected regions, and the difference between the total numbers of students from two regions should be minimized. Can you help the juries to find the minimum difference?

Input
There are multiple test cases in the input file. Each test case starts with two integers N and M, (1 ≤ N ≤ 100000, 1 ≤ M ≤ 1000000), the number of universities and the number of direct communication line set up by the committee, respectively. Universities are numbered from 1 to N. The next line has N integers, the Kth integer is equal to the number of students in university numbered K. The number of students in any university does not exceed 100000000. Each of the following M lines has two integers s, t, and describes a communication line connecting university s and university t. All communication lines of this new system are bidirectional.

N = 0, M = 0 indicates the end of input and should not be processed by your program.

Output
For every test case, output one integer, the minimum absolute difference of students between two regions in the format as indicated in the sample output.

Sample Input
7 6
1 1 1 1 1 1 1
1 2
2 7
3 7
4 6
6 2
5 7
0 0

Sample Output
Case 1: 1

题目大意
给你一个n个结点,m条边组成的图(由题意可知就是一棵树),找到一条边,使得删除该边后,被分成两部分的连通图的结点和之差最小,并输出该最小差值。

解题思路
也是一道树型dp的问题,详细题解见http://blog.csdn.net/u013008291/article/details/43916435。还是用了边的存储方式,也可以用vector存,写起来更简单,见http://blog.csdn.net/xuanandting/article/details/53008740

代码

#include<iostream>
#include<string.h>
#include<cmath>
#include<algorithm>
#define inf 0x3f3f3f3f3f3f3f3f  
using namespace std;
struct Edge
{
    int to;
    int next;
}edge[200005];
int head[100005];
long long dp[100005];
long long tot,sum,ans;
int n,m;
long long llAbs(long long a)
{
    if(a>=0)
    return a;
    else return -a; 
}
void addedge(int u,int v)
{
    edge[tot].to=v;
    edge[tot].next=head[u];
    head[u]=tot++;
}
void dfs(int u,int fa)
{
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].to;
        if(v==fa)
        continue;
        dfs(v,u);
        dp[u]+=dp[v];
    }
}

int main()
{
    long long u,v,cnt;
    cnt=1;
    while(cin>>n>>m)
    {
        if(n==0&&m==0)
        break;
        sum=0;
        tot=0;

        memset(head,-1,sizeof(head));
        for(int i=1;i<=n;i++)
        {
            cin>>dp[i];
            sum+=dp[i];
        }
        for(int i=1;i<=m;i++)
        {
            cin>>u>>v;
            addedge(u,v);
            addedge(v,u);
        }


        ans=inf;
        dfs(1,-1);
        for(int i=1;i<=n;i++)
        ans=min(ans,llAbs(sum-2*dp[i]));

        cout<<"Case "<<cnt++<<": "<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值