面向对象程序设计上机练习六(类和对象)

面向对象程序设计上机练习六(类和对象)

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
用类成员函数完成5个整型数组元素的输入、从小到大排序、排序后数组元素的输出。
Input
输入5个数组元素。
Output
输出5个数组元素从小到大排序后的结果。(最后一个数后面既没有空格也没有换行)
Example Input
8 9 1 5 4
Example Output
1 4 5 8 9
 
#include <iostream>
#include <cstdio>
using namespace std;
class Time{
private:
int a[6];
public:
void input()
{
for(int i=0;i<5;i++)
cin>>a[i];
}
void sort()
{
int t;
for(int i=0;i<4;i++)
for(int j=0;j<4-i;j++)
{
if(a[j]>a[j+1])
{
t=a[j];
a[j]=a[j+1];
a[j+1]=t;
}
}
}
void show()
{
int i;
for(i=0;i<4;i++)
cout<<a[i]<<" ";
cout<<a[i]<<endl;
}
};
int main()
{
Time t;
t.input();
t.sort();
t.show();
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值