面向对象程序设计上机练习七(类和对象)
Time Limit: 1000MS
Memory Limit: 65536KB
Problem Description
利用类的数据成员和成员函数完成下列操作:输入三个整数,输出它们的最大值。
Input
输入三个整数。
Output
输出3个整数的最大值。
Example Input
2 8 5
Example Output
8
#include <cstdio>
using namespace std;
class Time{
private:
int a[6];
int t;
public:
void input()
{
for(int i=0;i<3;i++)
cin>>a[i];
}
void Max()
{
for(int i=0;i<2;i++)
for(int j=0;j<2-i;j++)
{
if(a[j]<a[j+1])
{
t=a[j];
a[j]=a[j+1];
a[j+1]=t;
}
}
}
void show()
{
cout<<a[0]<<endl;
}
};
int main()
{
Time t;
t.input();
t.Max();
t.show();
return 0;
}