实验10-2 判断满足条件的三位数 (15 分)(python)

本题要求实现一个函数,统计给定区间内的三位数中有两位数字相同的完全平方数(如144、676)的个数。

函数接口定义:

int search( int n );

其中传入的参数int n是一个三位数的正整数(最高位数字非0)。函数search返回[101, n]区间内所有满足条件的数的个数。

裁判测试程序样例:

#include <stdio.h>
#include <math.h>

int search( int n );

int main()
{
    int number;

    scanf("%d",&number);
    printf("count=%d\n",search(number));
        
    return 0;
}


/* 你的代码将被嵌在这里 */

 

输入样例:

500

输出样例:

count=6

python代码如下:

m = int(input())
result = 0
num = 0
for i in range(10,m+1):        #前面的9*9=81不满足三位数条件,所以从10开始
    result = i**2
    if result > 999:
        break
    else:
        l = list(str(result))
        # print(l)
        if l[0] == l[1] and l[0] != l[2]:
            num += 1
        elif l[1] == l[2] and l[1] != l[1]:
            num += 1
        elif l[1] == l[2] and l[0] != l[2]:
            num += 1

print("count={}".format(num))

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值