HDU3336 Count the string(KMP+DP)

这篇博客讨论了一种字符串处理问题,即计算一个字符串所有非空前缀在原字符串中出现的次数之和。传统的KMP算法在这种情况下效率较低,作者提出了使用动态规划的方法优化,通过next[]数组的性质来实现。代码展示了一个C++实现,通过状态转移方程f[i]=f[ne[i]]+1计算每个前缀的匹配次数,并求模10007以防止答案过大。该方法显著降低了时间复杂度,适用于处理大规模字符串数据。
摘要由CSDN通过智能技术生成
题目描述

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: “abab”
The prefixes are: “a”, “ab”, “aba”, “abab”
For each prefix, we can count the times it matches in s. So we can see that prefix “a” matches twice, “ab” matches twice too, “aba” matches once, and “abab” matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For “abab”, it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

Input

The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input
1
4
abab
Sample Output
6

题目大意

给出一个字符串s,枚举所有的前缀,输出所有前缀出现的次数。

题目分析

题目要求的是所有的前缀在字符串中出现的次数。如果仅仅是每次求一遍KMP,那么复杂度是O(n2),肯定是要超时的,所以我们要想一个更优的解法。
我们想想KMP的next[]数组的原理是什么:next[i]就是i前面前缀重复的上一个位置
因此我们可以发现:当next[i]=j时,说明长度为j的前缀在i位置上有一个重复。
推出了这个结论之后,我们就可以用dp的方式来写了。状态转移方程为:f[i]=f[ne[i]]+1;

代码如下
#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <map>
#include <queue>
#include <vector>
#include <set>
#include <algorithm>
#include <iomanip>
#define LL long long
#define ULL unsigned long long
#define PII pair<int,int>
#define x first
#define y second
using namespace std;
const int N=1e6+5,mod=10007;
char s[N];
int ne[N],f[N];
void getNext(int n)
{
    for(int i=2,j=0;i<=n;i++)
    {
        while(j&&s[i]!=s[j+1]) j=ne[j];
        if(s[i]==s[j+1]) j++;
        ne[i]=j;
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d %s",&n,s+1);
        getNext(n);
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            f[i]=f[ne[i]]+1;
            ans=(ans+f[i])%mod;
        }
        printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

lwz_159

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值