POJ 3274 Gold Balanced Lineup

5 篇文章 0 订阅
Gold Balanced Lineup
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 14378 Accepted: 4165

Description

Farmer John's N cows (1 ≤ N ≤ 100,000) share many similarities(类似). In fact, FJ has been able to narrow down the list of features(特色) shared by his cows to a list of only K different features (1 ≤ K ≤ 30). For example, cows exhibiting(展览) feature #1 might have spots, cows exhibiting feature #2 might prefer C to Pascal, and so on.

FJ has even devised(设计) a concise(简明的) way to describe each cow in terms of its "feature ID", a single K-bit integer(整数) whose binary(二进制的) representation(代表) tells us the set of features exhibited by the cow. As an example, suppose a cow has feature ID = 13. Since 13 written in binary is 1101, this means our cow exhibits features 1, 3, and 4 (reading right to left), but not feature 2. More generally, we find a 1 in the 2^(i-1) place if a cow exhibits feature i.

Always the sensitive(敏感的) fellow, FJ lined up cows 1..N in a long row and noticed that certain ranges of cows are somewhat "balanced" in terms of the features the exhibit. A contiguous(连续的) range of cows i..j is balanced if each of the K possible features is exhibited by the same number of cows in the range. FJ is curious as to the size of the largest balanced range of cows. See if you can determine it.

Input

Line 1: Two space-separated   integers (整数),   N  and   K.
Lines 2.. N+1: Line   i+1 contains a single   K-bit integer   specifying (指定)  the   features (特色)  present in cow   i. The least-significant bit of this integer is 1 if the cow   exhibits (展览品)  feature #1, and the most-significant bit is 1 if the cow exhibits feature # K.

Output

Line 1: A single integer giving the size of the largest   contiguous (连续的)  balanced group of cows.

Sample Input

7 3
7
6
7
2
1
4
2

Sample Output

4

Hint

In the range from cow #3 to cow #6 (of size 4), each   feature (特色)  appears in exactly 2 cows in this range

用vector一直在超时,无奈换成了链式前向星,然后就A了。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<cmath>

using namespace std;

int a[112345][35];

struct node
{
    int num;
    int next;
}b[112345];
int hs[112345];
int ans;
int m,k;
int  in =99991;

void push(int key,int i)
{
    b[ans].num=i;
    b[ans].next=hs[key];
    hs[key]=ans;
    ans++;
}

void ck(int key,int i)
{
    int you=hs[key],flag=1;
    while(you!=-1)
    {
        int tt=1;
        for(int j=2;j<=k;j++)
        {
            if(a[b[you].num][j]!=a[i][j])
            {
                tt=0;
                break;
            }
        }
        if(tt)
        {
            m=max(m,(i-b[you].num));
        }
        you=b[you].next;
    }
    if(flag) push(key,i);
}

int main()
{
    int n;
    cin>>n>>k;
    ans=0;
    memset(a,0,sizeof(a));
    for(int i=0;i<=99992;i++) hs[i]=-1;
    for(int i=1;i<=n;i++)
    {
        int x;
        scanf("%d",&x);
        int top=k;
        while(x>0)
        {
            a[i][top--]=x%2;
            x/=2;
        }
    }
    for(int i=2;i<=n;i++)
    for(int j=1;j<=k;j++) a[i][j]=a[i][j]+a[i-1][j];
    for(int i=1;i<=n;i++)
    for(int j=2;j<=k;j++) a[i][j]=a[i][j]-a[i][1];
    for(int i=1;i<=k;i++) a[0][i]=0;
    push(0,0);
    m=0;
    for(int i=1;i<=n;i++)
    {
        int key=0;
        for(int j=2;j<=k;j++) key+=a[i][j];
        key=abs(key)%in;
        if(hs[key]==-1) push(key,i);
        ck(key,i);
    }
    cout<<m<<endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值