HDU_1712_背包问题

Description

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit? 
 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has. 
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j]. 
N = 0 and M = 0 ends the input. 
 

Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain. 
 

Sample Input

       
       
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 

Sample Output

       
       
3 4 6
 
题意就是告诉你每门课程话费一定天数,所能获得的知识。
让你列一个计划,让你所能获得的知识最大
dp[i][j]的意义是学习前i们课程话费j天所能获得的最大知识
我们首先应该明确状态转移方程
dp[i+1][j] = max(dp[i][j]+dp[i][j-k]+A[i][k]||k<=j)
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define MAX_N 105
#define MAX_M 105
int n;//课程数目
int m;//总天数
//dp[i+1][j]表示学习前i门课程消耗j天所获得最大价值
/**
    //状态转移方程
    dp[i+1][j]=max(dp[i][j],dp[i][j-k]+A[i][k]|k<=j)
*/
int dp[MAX_N][MAX_M];

//A[i][j]代表花j天在第i门课上所获得的价值
int A[MAX_N][MAX_M];
int main()
{
    //freopen("背包D.txt","r",stdin);
    while(~scanf("%d %d",&n,&m))
    {
        if(n==m&&m==0)
        {
            break;
        }
        for(int i=0;i<n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                scanf("%d",&A[i][j]);
            }
        }
        for(int i=0;i<n;i++)
        {
            A[i][0]=0;
        }
        void solve();
        solve();
    }

}
void solve()
{
    memset(dp,0,sizeof(dp));
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<=m;j++)
        {
<span style="white-space:pre">	</span>    //对所能学习的天数进行枚举
            for(int k=0;k<=j;k++)
            {
                //dp[i][j]代表学习前i门课程所占j天所获得的最大价值
                dp[i+1][j]=max(dp[i+1][j],dp[i][j-k]+A[i][k]);
            }
        }
    }
    printf("%d\n",dp[n][m]);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值