广度优先搜索+队列 - Knight Moves(2021-7-23))

Knight (骑士)Moves

题目链接

Background
Mr Somurolov, fabulous chess-gamer indeed, asserts(断言) that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.
请添加图片描述

Input

The input begins with the number n of scenarios(方案) on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, …, l-1}*{0, …, l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

思路: 广度优先搜索——最短路径
广度优先搜索:(1)queue q dis[i]=-1//借助队列,同时标志该店是否被访问
(2)放入起点 q.push(x); dis[x]=0;
(3)如果队列非空,取队头,找队头周围能达到的所有点(非访问)
(4)再放入队列中,同时标记
(5)队列空,停止

#include<iostream>
#include<queue>
#include<string.h>
using namespace std;
struct Node{
	int x,y;
	Node(int x,int y):x(x),y(y){
		
	}
};
int point[8][2]={{-2,1},{-1,2},{1,2},{2,1},{-2,-1},{-1,-2},{1,-2},{2,-1}};
queue<Node> q;
int dis[305][305];//计算距离同时充当标志位
int main(){
	
	int n;
	int l;
	int x,y;//起始
	int xx,yy;//结束 
	cin>>n;
	while(n--){
		memset(dis,-1,sizeof(dis));
		cin>>l;
		cin>>x>>y;
		cin>>xx>>yy;
		q.push(Node(x,y));//放入起点 
		dis[x][y]=0;
		while(!q.empty()){//队列非空 
			Node N = q.front();//取队头 
			q.pop();
			Node tmp(0,0);
			for(int i=0;i<8;i++){
				tmp.x=N.x+ point[i][0];
				tmp.y=N.y+ point[i][1];
				if(tmp.x>=0&&tmp.x<l&&tmp.y>=0&&tmp.y<l&&dis[tmp.x][tmp.y]==-1){
					dis[tmp.x][tmp.y]=dis[N.x][N.y]+1;//距离=上一结点距离+1 
					q.push(tmp);//找队头周围能到达的所有点(未访问)
				}
					
			}
		} 
		cout<<dis[xx][yy]<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值