Crossing River 贪心

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won’t be more than 1000 people and nobody takes more than 100 seconds to cross.
Output
For each test case, print a line containing the total number of seconds required for all the N people to cross the river.
Sample Input
1
4
1 2 5 10
Sample Output
17

解题思路

本题是用贪心做的,首先分开讨论
当n=1时,时间是第一个用的时间。
当n=2时,时间是两人用的最长的。
当n=3时,时间是3人的总和。
当n=4时,分2种情况。
第一种是用最快的运最慢的。
第二种是最快的和次快的先过去,然后最快的回来,再让最慢的和次慢的过去,让次快的回来,最后次快的和最快的再过河。
列如1 2 5 10
第一种是1和10过去,1回来,然后1和5过去,1回来,最后1和2过去。总时间是11+6+2=19.
第二种是1和2过去,1回来,然后5和10过去,2回来,最后1和2过去。总时间是3+10+2+2=17.
当n>4时,比较运送最慢的和次慢的用第一种和第二种那个时间少,选取少的。
重复上述步骤。

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=1e5+10;
int a[maxn];
int n;
int fun(){//第一种的函数 
	return a[0]*2+a[n-1]+a[n-2];
}
int qwe(){//第二种的函数 
	return a[0]+a[1]*2+a[n-1];
}
int main(){
	int t;
	cin>>t;
	while(t--){
		cin>>n;
		if(n==0){
			cout<<"0"<<"\n";
			continue;//注意要特判下n==0的情况 
		} 
		for(int i=0;i<n;i++){
			cin>>a[i];
		}
		sort(a,a+n);
		if(n==1){
			cout<<a[0]<<"\n";
			continue;
		}
		if(n==2){
			cout<<a[1]<<"\n";
			continue; 
		}
		if(n==3){
			cout<<a[0]+a[1]+a[2]<<"\n";
			continue;
		}
		int ans=0;
		do{
			if(fun()>qwe()){
				ans+=qwe();
			}
			else ans+=fun();
			n-=2;
		}while(n>3);
		if(n==1){
			cout<<ans+a[0]<<"\n";
		}
		if(n==2){
			cout<<ans+a[1]<<"\n";
		}
		if(n==3){
			cout<<ans+a[0]+a[1]+a[2]<<"\n";
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值