HDU 1061 Rightmost Digit(快速幂取模)

                                           Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45296    Accepted Submission(s): 17031


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 
Author
Ignatius.L

题解:快速幂取模!!!

#include<iostream>
#include<cstdio>
int qmod(long long a,long long b,int c)
{
	int ans=1;
	a=a%c;
	while(b>0){
		if(b&1)
		ans=(ans*a)%c;
		b=b>>1;
		a=(a*a)%c;
	}
	return ans;
}
int main()
{
	int n;  long long t;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%lld",&t);
		printf("%d\n",qmod(t,t,10));
	}
	
	return 0;
}

听说是ans的周期是20......(无语。。。)

#include<stdio.h>
int main()
{
	int T,n;
	int a[25]={0,1,4,7,6,5,6,3,6,9,0,1,6,3,6,5,6,7,4,9,0};
	
	scanf("%d",&T);
	
	while(T--)
	{
		scanf("%d",&n);
		printf("%d\n",a[n%20]);
		
	}
	return 0;
}



  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值