A + B Again
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 21951 Accepted Submission(s): 9489
Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.
Output
For each test case,print the sum of A and B in hexadecimal in one line.
Sample Input
+A -A +1A 12 1A -9 -1A -12 1A -AA
Sample Output
0 2C 11 -2C -90
Author
linle
题解:注意输出的字母是大写的
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
typedef long long LL;
using namespace std;
int main()
{
LL a,b;
while(scanf("%llX %llX",&a,&b)!=EOF)
{
getchar();
b+=a;
if(b<0)
{
b=-b;
printf("-");
}
printf("%llX\n",b);
}
/*
LL a,b;
while(cin>>hex>>a>>b)
{
LL t=a+b;
if(t<0)
cout<<'-'<<setiosflags(ios::uppercase)<<hex<<-t<<endl;
else
cout<<setiosflags(ios::uppercase)<<hex<<a+b<<endl;
}
*/
return 0;
}
AC代码: