HDU 2057 A + B Again(16进制加法)

A + B Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21951    Accepted Submission(s): 9489

Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

Output
For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input
  
  
+A -A +1A 12 1A -9 -1A -12 1A -AA

Sample Output
  
  
0 2C 11 -2C -90

Author
linle
 
题解:注意输出的字母是大写的
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
typedef long long LL;
using namespace std;
int main()
{
	LL a,b;
	while(scanf("%llX %llX",&a,&b)!=EOF) 
	{
	     getchar(); 
		b+=a;
		if(b<0)
		{
			b=-b;
			printf("-"); 
		}
		printf("%llX\n",b); 
	}
	/*
	LL a,b;
    while(cin>>hex>>a>>b)
    {
        LL t=a+b;
        if(t<0)
            cout<<'-'<<setiosflags(ios::uppercase)<<hex<<-t<<endl;
        else
            cout<<setiosflags(ios::uppercase)<<hex<<a+b<<endl;

    }
       */
    return 0;
}


AC代码:

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值