HDU 5718 BestCoder 2nd Anniversary Oracle (模拟)

Oracle

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 547    Accepted Submission(s): 237

Problem Description
There is once a king and queen, rulers of an unnamed city, who have three daughters of conspicuous beauty.
The youngest and most beautiful is Psyche, whose admirers, neglecting the proper worship of the love goddess Venus, instead pray and make offerings to her. Her father, the king, is desperate to know about her destiny, so he comes to the Delphi Temple to ask for an oracle.

The oracle is an integer n without leading zeroes.
To get the meaning, he needs to rearrange the digits and split the number into <b>two positive integers without leading zeroes</b>, and their sum should be as large as possible.

Help him to work out the maximum sum. It might be impossible to do that. If so, print `Uncertain`.

Input
The first line of the input contains an integer T (1T10) , which denotes the number of test cases.

For each test case, the single line contains an integer n (1n<1010000000) .

Output
For each test case, print a positive integer or a string `Uncertain`.

Sample Input
  
  
3 112 233 1

Sample Output
  
  
22 35 Uncertain
Hint
In the first example, it is optimal to split $ 112 $ into $ 21 $ and $ 1 $, and their sum is $ 21 + 1 = 22 $. In the second example, it is optimal to split $ 233 $ into $ 2 $ and $ 33 $, and their sum is $ 2 + 33 = 35 $. In the third example, it is impossible to split single digit $ 1 $ into two parts.
Source
 
Recommend
wange2014   |   We have carefully selected several similar problems for you:  5722 5721 5720 5717 5716 

题意:将一个数任意排列后分成两个数,使这两个数加起来最大。

题解:sort 一下,再模拟一下。。。

AC代码:
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm> 
using namespace std;
const int N=1e7+10;
char s[N];
int a[N];
int main()
{
    int t,i;
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        scanf("%s",s);
        int len=strlen(s);
        sort(s,s+len);
        int k=0;
        for(i=0; i<len; i++)
            if(s[i]!='0') //记录第一个不是 0 的位置 
            {
                k=i;
                break;
            }
            
        if(len==1||k==len-1)
        {
            printf("Uncertain\n");
            continue;
        }
        int j=0;
        for(i=0; i<len; i++)
            if(i!=k)
                a[j++]=s[i]-'0';
        int x=s[k]-'0';
        a[0]+=x;
        for(i=0; i<j; i++)
            if(a[i]>9)
            {
                a[i+1]++;
                a[i]%=10;
            }
            else
                break;
                
        if(a[j])
            printf("%d",a[j]);
        for(i=j-1;i>=0;i--)
            printf("%d",a[i]);
        printf("\n");
    }
    return 0;
}


 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值