HDU 1987 Decoding (模拟)

本文介绍了一种基于螺旋矩阵的文本加密与解密方法。该方法通过预先约定的矩阵行列数,将字符转换为二进制数值并按照螺旋路径填充到矩阵中。文章详细解析了编码过程,并提供了一个具体的解码示例及其对应的AC代码。
摘要由CSDN通过智能技术生成

Decoding

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 810    Accepted Submission(s): 253

Problem Description
Chip and Dale have devised an encryption method to hide their (written) text messages. They first agree secretly on two numbers that will be used as the number of rows (R) and columns (C) in a matrix. The sender encodes an intermediate format using the following rules:
1. The text is formed with uppercase letters [A-Z] and <space>.
2. Each text character will be represented by decimal values as follows:
<space> = 0, A = 1, B = 2, C = 3, ..., Y = 25, Z = 26
The sender enters the 5 digit binary representation of the characters’ values in a spiral pattern along the matrix as shown below. The matrix is padded out with zeroes (0) to fill the matrix completely. For example, if the text to encode is: "ACM" and R=4 and C=4, the matrix would be filled in as follows:



The bits in the matrix are then concatenated together in row major order and sent to the receiver.
The example above would be encoded as: 0000110100101100
Input
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.
Each dataset consists of a single line of input containing R (1<=R<=20), a space, C (1<=C<=20), a space, and a string of binary digits that represents the contents of the matrix (R * C binary digits).
The binary digits are in row major order.
Output
For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the decoded text message. You should throw away any trailing spaces and/or partial characters found while decoding.
Sample Input
  
  
4 4 4 0000110100101100 5 2 0110000010 2 6 010000001001 5 5 0100001000011010110000010
Sample Output
  
  
1 ACM 2 HI 3 HI 4 HI HO
Source

Recommend
linle   |   We have carefully selected several similar problems for you:  1993 1984 1988 1990 1992 

题解:好麻烦的模拟...

AC代码:
#include<bits/stdc++.h>
using namespace std;

char a[28]={" ABCDEFGHIJKLMNOPQRSTUVWXYZ"};

int convert(char *s)
{   
	int sum=0;
	for(int i=0; i<5; i++)
	{
		sum *=2;
		sum += s[i]-'0';
	}
	return sum;
}

void convert_again(char *sss,int n,int m)
{
	char temp[1000]="";
	char space[2]=" ";
	char s[6];
	s[5] = '\0';
	char ss[22][22];
	char *p=sss;
	for(int i=0; i<n; i++)
	{
		strncpy(ss[i],p,m);
		ss[i][m]='\0';
		p +=m;
	}

	int b1,b2,t,tt; //b1低行,b2低列,t,高行,tt 高列;
	b1 = b2 = 0;
	t = n;
	tt = m;
	int k=0;
	int g=0;
	int tst=0;
	int begin=1;
	while(1)
	{
		if(b1>=t||b2>=tt) break;
		for(g=b2; g<tt; g++)
		{
			s[k++] = ss[b1][g];
			if(k == 5)
			{
				if(a[convert(s)]!=' ')
				{
					printf("%s",temp);
					strcpy(temp,"");
					printf("%c",a[convert(s)]);
					tst+=5;
					begin=0;
				}
				else
				{
					if(!begin)
					{
						strcat(temp,space);
					}
				}
				k=0;
			}
		}
		b1++;
		if(b1>=t||b2>=tt) break;
		for(g=b1; g<t; g++)
		{
			s[k++] = ss[g][tt-1];
			if(k == 5)
			{
				if(a[convert(s)]!=' ')
				{
					printf("%s",temp);
					strcpy(temp,"");
					printf("%c",a[convert(s)]);
					tst+=5;
					begin=0;
				}
				else
				{
					if(!begin)
					{
						strcat(temp,space);
					}
				}
				k=0;
			}
		}
		tt--;
		if(b1>=t||b2>=tt) break;
		for(g=tt-1; g>=b2; g--)
		{
			s[k++] = ss[t-1][g];
			if(k == 5)
			{
				if(a[convert(s)]!=' ')
				{
					printf("%s",temp);
					strcpy(temp,"");
					printf("%c",a[convert(s)]);
					tst+=5;
					begin=0;
				}
				else
				{
					if(!begin)
					{
						strcat(temp,space);
					}
				}
				k=0;
			}
		}
		t--;
		if(b1>=t||b2>=tt) break;
		for(g=t-1; g>=b1; g--)
		{
			s[k++] = ss[g][b2];
			if(k == 5)
			{
				if(a[convert(s)]!=' ')
				{
					printf("%s",temp);
					strcpy(temp,"");
					printf("%c",a[convert(s)]);
					tst+=5;
					begin=0;
				}
				else
				{
					if(!begin)
					{
						strcat(temp,space);
					}
				}
				k=0;
			}
		}
		b2++;
		if(b1>=t||b2>=tt) break;
	}	
}

int main()
{
	int t,r,c;
	scanf("%d",&t);
	int cas=1;
	while(t--)
	{   
		
		char s[410];
		scanf("%d%d%s",&r,&c,s);
		printf("%d ",cas++);
		convert_again(s,r,c);
		puts("");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值