poj 1742 Coins 背包dp

Description
People in Silverland use coins.They have coins of value A1,A2,A3…An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains

2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.
Output
For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output
8
4
Source
LouTiancheng@POJ

大意:给你n种硬币的面值,每种面值有价格和该种硬币的个数,问可以组成多少种<=m的价值。多组数据。

分析:一个典型的多重背包,我用O(nm)的算法总是TLE,有点不懂。j,k一个枚举倍数,一个枚举余数,只是相当于一维m,只能换种奇怪算法,其实也是一个样。这个多组数据好像并没有说清楚,有点坑。

代码(tle):

#include <iostream>
#include <cstdio>

const int maxn=1e5+7;
const int N=105;

using namespace std;

int f[maxn],a[N],c[N],n,m,i;
int j,k,g,ans,t,q;

void dp()
{
    ans=0;
    f[0]=1; 
    for (i=1;i<=n;i++)
    {
        for (j=0;j<a[i];j++)
        {
            t=f[j];
            g=0;
            int e=(m-j)/a[i];
            for (k=1;k<=e;k++)
            {
                q=k*a[i]+j;
                if (f[q]==1)
                {
                    g=k;
                    t=1;
                }
                else
                if ((t==1) && (k-g<=c[i]))
                {
                    f[q]=1;
                    ans++;
                }
            }
        }
    }
    printf("%d\n",ans);
    return;
}

int main()
{
    while (1==1)
    {
        scanf("%d%d",&n,&m);
        if ((n==0) || (m==0)) return 0; 
        for (i=0;i<=m;i++)
        f[i]=0;
        for (i=1;i<=n;i++)
        scanf("%d",&a[i]);
        for (i=1;i<=n;i++)
        scanf("%d",&c[i]);          
        dp();
    } 
} 

代码(AC):

#include <cstdio>
#include <cstring>
using namespace std;

const int M = 100005;
const int N = 105;
int d[M];
int n,a[N],c[N],m;

void solve()
{
memset(d, -1, sizeof(d));
d[0] = 0;

for(int i = 0; i < n; i++)
{
for(int j = 0; j <= m; j++)
{
if(d[j] >= 0) d[j] = c[i];
else if(j < a[i] || d[j-a[i]]<= 0)
d[j] = -1;
else d[j] = d[j-a[i]]-1;
}
}

int ans = 0;
for(int i = 1; i <= m; i++)
if(d[i]>=0) ans++;
printf("%d\n", ans);
}

int main()
{
   while(~scanf("%d %d", &n, &m) &&(n||m))
{
for(int i = 0; i < n; i++) scanf("%d", a+i);
for(int i = 0; i < n; i++) scanf("%d", c+i);
solve();
}
return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值