PAT 甲级1002_A+B for Polynomials (25)

1002. A+B for Polynomials (25)


时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: 
K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, 
Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. 
Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.


Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output

3 2 1.5 1 2.9 0 3.2   

#include<stdio.h>
int main()
{
	int k,n,k1,k2,nk1[20],nk2;
	float a1[20],a2;
	scanf("%d",&k1);
	k=k1,n=k1;
	for(int i=0;i<k1;i++)scanf("%d %f",&nk1[i],&a1[i]);
	scanf("%d",&k2);
	for(int i=0;i<k2;i++)
	{
	    scanf("%d %f",&nk2,&a2);   //输入数值的话,scanf会跳过空格和转行 
	    int j;
	    for(j=0;j<k1;j++)
	    {
	    	if(nk2==nk1[j])   //系数相同 
	    	{
	    		a1[j]+=a2;
	    		if(a1[j]==0)
				{
				    nk1[j]=-1;
				    n--;    //个数减一 
				}
	    		break;
			}
		}
		if(j==k1)  //新系数
		{
			nk1[k]=nk2;
			a1[k]=a2;
			k++;       //新长度, 
			n++;     //个数加一 
		} 
    }
    if(n)
    {
	    printf("%d ",n);
        for(int i=0;i<k;i++)
        {
        	if(nk1[i]!=-1)
        	{
        		for(int j=i+1;j<k;j++)    //排序 
				{
					if(nk1[i]<nk1[j])
					{
						int x;
						float y;
						x=nk1[i],nk1[i]=nk1[j],nk1[j]=x;
						y=a1[i],a1[i]=a1[j],a1[j]=y;
					}
				} 
    		    printf("%d %.1f",nk1[i],a1[i]);  //最大的那个输出。 
    		    n--;
    		    if(n)printf(" ");   //不是最后一个输出空格 
    		    else break;
	    	}
    	}
    }
    else printf("0");   //格式 
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值