PAT甲级1030. Travel Plan (30)

A traveler’s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:
City1 City2 Distance Cost
where the numbers are all integers no more than 500, and are separated by a space.
Output Specification:
For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.
Sample Input
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output
0 2 3 3 40

很基础的DFS。用Dijkstra也可以做。

//DFS
#include <cstdio>
using namespace std;
#include <vector>

const int MAX=500+10;
int len[MAX][MAX]={0},cost[MAX][MAX]={0};
int vis[MAX]={0};
int currentLen=0,currentCost=0;
int minLen=(1<<30),minCost=(1<<30);
vector<int> path,ans;
int N,M,S,D;

void DFS(int s){
    if(currentLen>minLen) return;
    if(s==D) {
        if(currentLen<minLen){
            minLen=currentLen;
            minCost=currentCost;
            ans=path;
        }
        else if(currentLen==minLen&&currentCost<minCost){
            minCost=currentCost;
            ans=path;
        }
    }
    for(int i=0;i<N;i++){
        if(vis[i]==0&&len[s][i]!=0){
            vis[i]=1;
            path.push_back(i);
            currentLen+=len[s][i];
            currentCost+=cost[s][i];
            DFS(i);

            vis[i]=0;
            path.pop_back();
            currentLen-=len[s][i];
            currentCost-=cost[s][i];
        }
    }
}

int main(){
    scanf("%d %d %d %d",&N,&M,&S,&D);

    for(int i=0;i<M;i++){
        int City1,City2,Distance,Money;
        scanf("%d %d %d %d",&City1,&City2,&Distance,&Money);
        len[City1][City2]=Distance;
        len[City2][City1]=Distance;
        cost[City1][City2]=Money;
        cost[City2][City1]=Money;
    }

    vis[S]=1;
    DFS(S);

    printf("%d",S);
    for(int i=0;i<ans.size();i++){
        printf(" %d",ans[i]);
    }
    printf(" %d %d",minLen,minCost);

    return 0;
}
//Dijkstra
#include <cstdio>
using namespace std;
#include <vector>
#include <queue>

const int MAX=500+10;
const int INF=(1<<30);
int len[MAX][MAX],cost[MAX][MAX];
int pre[MAX];
int dis[MAX];
int minCost[MAX];
int vis[MAX]={0};

void PrintRoute(int S,int D){
    if(S==D) {
        printf("%d ",S);
        return;
    }
    PrintRoute(S,pre[D]);
    printf("%d ",D);
}

int main(){
    int N,M,S,D;
    scanf("%d %d %d %d",&N,&M,&S,&D);

    //初始化 
    for(int i=0;i<MAX;i++){
        dis[i]=INF;
        pre[i]=-1;
        for(int j=0;j<MAX;j++){
            if(i==j) {
                len[i][j]=0;
                cost[i][j]=0;
            }
            else{
                len[i][j]=INF;
                cost[i][j]=INF;
            }
        }
    }

    //邻接矩阵 
    for(int i=0;i<M;i++){
        int City1,City2,Distance,Money;
        scanf("%d %d %d %d",&City1,&City2,&Distance,&Money);
        len[City1][City2]=Distance;
        len[City2][City1]=Distance;
        cost[City1][City2]=Money;
        cost[City2][City1]=Money;
    }

    priority_queue<int,vector<int>,greater<int> > PQ;
    dis[S]=0;
    minCost[S]=0;
    PQ.push(S);
    while(!PQ.empty()){
        int v=PQ.top();  //smallest unknown distance vertex
        PQ.pop();
        vis[S]=1;
        for(int w=0;w<N;w++){
            if(vis[w]==0&&len[v][w]<INF){   //for each unknown vertex w adjacent to v
                if(dis[v]+len[v][w]<dis[w]) {
                    dis[w]=dis[v]+len[v][w];
                    minCost[w]=minCost[v]+cost[v][w];
                    pre[w]=v;
                    PQ.push(w);
                }
                else if(dis[v]+len[v][w]==dis[w]) {
                    if(minCost[v]+cost[v][w]<minCost[w]){
                        minCost[w]=minCost[v]+cost[v][w];
                        pre[w]=v;
                        PQ.push(w);
                    }
                }
            }
        }
    }

    PrintRoute(S,D);
    printf("%d %d",dis[D],minCost[D]);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值