PAT甲级1053. Path of Equal Weight (30)

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.
Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.
这里写图片描述
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.
Output Specification:
For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.
Note: sequence { A1,A2,...,An } is said to be greater than sequence { B1,B2,...,Bm } if there exists 1 <= k < min{n, m} such that Ai=Bifor i=1, … k, and Ak+1>Bk+1.
Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

#include <cstdio>
using namespace std;
#include <vector>
#include <algorithm>

int N,M,S;
vector<int> W; //weight of nodes
vector<vector<int> > G; //邻接表 
int vis[110];
vector<int> path;
vector<vector<int> > ans;
int currentSum=0;

bool compare(vector<int> &a,vector<int> &b){
    for(int i=0;i<a.size()&&i<b.size();i++){
        if(a[i]!=b[i]) return a[i]>b[i];
    }
    return a.size()>b.size();
}

void DFS(int s){
    vis[s]=1;
    if(G[s].size()==0&&currentSum==S){
        ans.push_back(path);
        return;
    }
    if(G[s].size()>0&&currentSum>S) return;
    for(int i=0;i<G[s].size();i++){
        currentSum+=W[G[s][i]];
        path.push_back(W[G[s][i]]);

        DFS(G[s][i]);

        currentSum-=W[G[s][i]];
        path.pop_back();

    }
}

int main(){
    scanf("%d %d %d",&N,&M,&S);

    W.resize(N);
    for(int i=0;i<N;i++) scanf("%d",&W[i]);

    G.resize(N);
    int ID,K,child;
    for(int i=0;i<M;i++){
        scanf("%d %d",&ID,&K);
        for(int j=0;j<K;j++) {
            scanf("%d",&child);
            G[ID].push_back(child);
        }
    }

    path.push_back(W[0]);
    currentSum=W[0];
    DFS(0);

    sort(ans.begin(),ans.end(),compare);
    for(int i=0;i<ans.size();i++){
        for(int j=0;j<ans[i].size();j++){
            if(j<ans[i].size()-1) printf("%d ",ans[i][j]);
            else printf("%d\n",ans[i][j]);
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值