BNU16494:Kinds of Fuwas

In the year 2008, the 29th Olympic Games will be held in Beijing. This will signify the prosperity of China as well as becoming a festival for people all over the world.

The official mascots of Beijing 2008 Olympic Games are Fuwa, which are named as Beibei, Jingjing, Haunhuan, Yingying and Nini. Fuwa embodies the natural characteristics of the four most popular animals in China -- Fish, Panda, Tibetan Antelope, Swallow -- and the Olympic Flame. To popularize the official mascots of Beijing 2008 Olympic Games, some volunteers make a PC game with Fuwa.

As shown in the picture, the game has a matrix of Fuwa. The player is to find out all the rectangles whose four corners have the same kind of Fuwa. You should make a program to help the player calculate how many such rectangles exist in the Fuwa matrix.

Input

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 50) which is the number of test cases. And it will be followed by T consecutive test cases.

The first line of each test case has two integers M and N (1 <= M, N <= 250), which means the number of rows and columns of the Fuwa matrix. And then there are M lines, each has N characters, denote the matrix. The characters -- 'B' 'J' 'H' 'Y' 'N' -- each denotes one kind of Fuwa.

Output

Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the number of the rectangles whose four corners have the same kind of Fuwa.

Sample Input

2
2 2
BB
BB
5 6
BJHYNB
BHBYYH
BNBYNN
JNBYNN
BHBYYH

Sample Output

1
8
 
题意:统计四角相等的矩形又几个
思路:枚举即可,先预定好矩形上边的左右端点,再一行行往下推,看以一样的符号位端点有几个,再用公式n*(n-1)/2统计这些能组成几个矩形,然后相加
 
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int find(char c)
{
    if(c == 'B')
        return 1;
    if(c == 'J')
        return 2;
    if(c == 'H')
        return 3;
    if(c == 'Y')
        return 4;
    if(c == 'N')
        return 5;
}
int s[10];
char map[255][255];

int main()
{
    int t,n,m,i,j,k,ans;
    scanf("%d",&t);
    while(t--)
    {
        ans = 0;
        scanf("%d%d",&n,&m);
        for(i = 0; i<n; i++)
            scanf("%s",map[i]);
        for(i = 0; i<m; i++)
        {
            for(j = i+1; j<m; j++)
            {
                memset(s,0,sizeof(s));
                for(k = 0; k<n; k++)
                {
                    if(map[k][i] == map[k][j])
                    {
                        int r = find(map[k][i]);
                        s[r]++;
                    }
                }
                for(k = 1; k<=5; k++)
                    ans+=s[k]*(s[k]-1)/2;
            }
        }
        printf("%d\n",ans);
    }


    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值