POJ2362:Square(DFS)

Description

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input

The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

Output

For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".

Sample Input

3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5

Sample Output

yes
no
yes
题意:看给出的所有棍子能不能组成正方形
思路:直接搜索每条边即可
 
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int a[250],vis[205],sum,l,n;

int dfs(int x,int pos,int len)
{
    if(x == 3)
        return 1;
    int i;
    for(i = pos; i>=0; i--)
    {
        if(!vis[i])
        {
            vis[i] = 1;
            if(len+a[i]<l)
            {
                if(dfs(x,i-1,len+a[i]))
                    return 1;
            }
            else if(len+a[i]==l)
            {
                if(dfs(x+1,n-1,0))
                    return 1;
            }
            vis[i] = 0;
        }
    }
    return 0;
}

int main()
{
    int t,i,j;
    scanf("%d",&t);
    while(t--)
    {
        sum = 0;
        scanf("%d",&n);
        for(i = 0; i<n; sum+=a[i],i++)
            scanf("%d",&a[i]);
        l = sum/4;
        memset(vis,0,sizeof(vis));
        sort(a,a+n);
        if(l*4!=sum || n<4 || l<a[n-1])//剪枝
        {
            printf("no\n");
            continue;
        }
        if(dfs(0,n-1,0))
            printf("yes\n");
        else
            printf("no\n");
    }

    return 0;
}

  • 5
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值