ZOJ3782:Ternary Calculation

Complete the ternary calculation.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a string in the form of "number1 operatora number2 operatorb number3". Each operator will be one of {'+', '-' , '*', '/', '%'}, and each number will be an integer in [1, 1000].

Output

For each test case, output the answer.

Sample Input
5
1 + 2 * 3
1 - 8 / 3
1 + 2 - 3
7 * 8 / 5
5 - 8 % 3
Sample Output
7
-1
0
11
3
Note

The calculation "A % B" means taking the remainder of A divided by B, and "A / B" means taking the quotient.

 

简单计算器问题,要注意中间过程都按整型处理

 

 

#include<stdio.h>
#include<string.h>
#include<stack>
using namespace std;
int main()
{
    int i,t;
    scanf("%d%*c",&t);
    int a,b;
    char s[250],c;
    while(t--)
    {
        gets(s);
        stack<char>s1;
        stack<int>s2;
        for(i=0; s[i]; i++)
        {
            if(s[i]>='0'&&s[i]<='9')
            {
                a=0;
                while(s[i]>='0'&&s[i]<='9')
                {
                    a=a*10+s[i]-'0';
                    i++;
                }
                i--;
                s2.push(a);
            }
            else if(s[i]=='-'||s[i]=='+')
            {
                if(!s1.empty())
                {
                    c=s1.top();
                    s1.pop();
                    a=s2.top();
                    s2.pop();
                    b=s2.top();
                    s2.pop();
                    if(c=='+')
                        a+=b;
                    else
                        a=b-a;
                    s2.push(a);
                    s1.push(s[i]);
                }
                else
                    s1.push(s[i]);
            }
            else if(s[i]=='/' || s[i] == '*' || s[i] == '%')
            {
                char ch = s[i];
                b=0;
                i+=2;
                while(s[i]>='0'&&s[i]<='9')
                {
                    b=b*10+s[i]-'0';
                    i++;
                }
                i--;
                a=s2.top();
                s2.pop();
                if(ch == '/')
                    a=a/b;
                else if(ch == '*')
                    a = a*b;
                else if(ch == '%')
                    a = a%b;
                s2.push(a);
            }
        }
        while(!s1.empty())
        {
            c=s1.top();
            s1.pop();
            a=s2.top();
            s2.pop();
            b=s2.top();
            s2.pop();
            if(c=='+')
                a+=b;
            else
                a=b-a;
            s2.push(a);
        }
        printf("%d\n",s2.top());
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值