HDU1667:The Rotation Game(IDA星)

Problem Description
The rotation game uses a # shaped board, which can hold 24 pieces of square blocks (see Fig.1). The blocks are marked with symbols 1, 2 and 3, with exactly 8 pieces of each kind.  

Initially, the blocks are placed on the board randomly. Your task is to move the blocks so that the eight blocks placed in the center square have the same symbol marked. There is only one type of valid move, which is to rotate one of the four lines, each consisting of seven blocks. That is, six blocks in the line are moved towards the head by one block and the head block is moved to the end of the line. The eight possible moves are marked with capital letters A to H. Figure 1 illustrates two consecutive moves, move A and move C from some initial configuration.  
 

Input
The input consists of no more than 30 test cases. Each test case has only one line that contains 24 numbers, which are the symbols of the blocks in the initial configuration. The rows of blocks are listed from top to bottom. For each row the blocks are listed from left to right. The numbers are separated by spaces. For example, the first test case in the sample input corresponds to the initial configuration in Fig.1. There are no blank lines between cases. There is a line containing a single `0' after the last test case that ends the input.  

 

Output
For each test case, you must output two lines. The first line contains all the moves needed to reach the final configuration. Each move is a letter, ranging from `A' to `H', and there should not be any spaces between the letters in the line. If no moves are needed, output `No moves needed' instead. In the second line, you must output the symbol of the blocks in the center square after these moves. If there are several possible solutions, you must output the one that uses the least number of moves. If there is still more than one possible solution, you must output the solution that is smallest in dictionary order for the letters of the moves. There is no need to output blank lines between cases.  

 

Sample Input
  
  
1 1 1 1 3 2 3 2 3 1 3 2 2 3 1 2 2 2 3 1 2 1 3 3 1 1 1 1 1 1 1 1 2 2 2 2 2 2 2 2 3 3 3 3 3 3 3 3 0
 

Sample Output
  
  
AC 2 DDHH 2


 

这道题跟HDU2234有点像,用IDA*来做的话,最主要的就是估测函数了,这里进行估测的就是中间环中海油几个不匹配的,这里的匹配,就是找出环内最多的数字,然后看还有多少个不相等的位置

 

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int map[10][10];
int hash[8] = {3,5,3,5,5,3,5,3};
char ans[100];
int step;

int get_h()
{
    int i,num[10]= {0};
    for(i=3; i<=5; i++)
    {
        num[map[3][i]]++;
        num[map[5][i]]++;
    }
    num[map[4][3]]++;
    num[map[4][5]]++;
    return max(num[1],max(num[2],num[3]));//找出最大的
}

void turn_col(int k,int flag)
{
    int i,tem;
    if(flag)
    {
        tem = map[1][k];
        for(i = 2; i<=7; i++)
            map[i-1][k] = map[i][k];
        map[7][k] = tem;
    }
    else
    {
        tem = map[7][k];
        for(i = 7; i>=2; i--)
            map[i][k] = map[i-1][k];
        map[1][k] = tem;
    }
}

void turn_row(int k,int flag)
{
    int i,tem;
    if(!flag)
    {
        tem = map[k][1];
        for(i = 2; i<=7; i++)
            map[k][i-1] = map[k][i];
        map[k][7] = tem;
    }
    else
    {
        tem = map[k][7];
        for(i = 7; i>=2; i--)
            map[k][i] = map[k][i-1];
        map[k][1] = tem;
    }
}

int dfs(int cnt)
{
    int tem = get_h(),i;
    if(tem==8 && cnt == step)
        return 1;
    if(cnt+(8-tem)>step)
        return 0;
    char c;
    for(i = 0; i<8; i++)
    {
        c = i+'A';
        ans[cnt] = c;
        if(c == 'A' || c == 'B')
        {
            turn_col(hash[i],1);
            if(dfs(cnt+1)) return 1;
            turn_col(hash[i],0);
        }
        else if(c == 'E' || c == 'F')
        {
            turn_col(hash[i],0);
            if(dfs(cnt+1)) return 1;
            turn_col(hash[i],1);
        }
        else if(c == 'C' || c == 'D')
        {
            turn_row(hash[i],1);
            if(dfs(cnt+1)) return 1;
            turn_row(hash[i],0);
        }
        else if(c == 'G' || c == 'H')
        {
            turn_row(hash[i],0);
            if(dfs(cnt+1)) return 1;
            turn_row(hash[i],1);
        }
    }
    return 0;

}

int main()
{
    int a,i,j,k;
    while(~scanf("%d",&a),a)
    {
        map[1][3] = a;
        scanf("%d",&a);
        map[1][5] = a;
        for(i = 2; i<=7; i++)
        {
            if(i == 3 || i == 5)
            {
                for(j = 1; j<=7; j++)
                    scanf("%d",&map[i][j]);
            }
            else
                scanf("%d%d",&map[i][3],&map[i][5]);
        }
        if(get_h() == 8)
        {
            printf("No moves needed\n%d\n",map[3][3]);//已经匹配就直接输出即可
            continue;
        }
        step = 1;
        while(1)
        {
            if(dfs(0))
                break;
            step++;
        }
        ans[step] = '\0';
        printf("%s\n%d\n",ans,map[3][3]);
    }

    return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值