ACdream1077:LCM Challenge

Problem Description

Some days ago, I learned the concept of LCM (least common multiple). I've played with it for several times and I want to make a big number with it.

But I also don't want to use many numbers, so I'll choose three positive integers (they don't have to be distinct) which are not greater thann. Can you help me to find the maximum possible least common multiple of these three integers?

Input
The first line contains an integer n (1 ≤ n ≤ 10^6) — the n mentioned in the statement.
Output
Print a single integer — the maximum possible LCM of three not necessarily distinct positive integers that are not greater than n.
Sample Input
9
Sample Output
504
 
 
题意:在n内找三个数,这三个数的最小公倍数,是n里面任意三个数的最小公倍数最大的
思路:这道题以前做过,但不记得在哪里了,思路就是找三个互质的数
奇数的话,那么n,n-1,n-2必定互质,那么n*(n-1)*(n-3)便是最大的
偶数的话,n-1是奇数,适用上面的式子,这是(n-1)*(n-2)*(n-3)
要么就是n,n-1,n-3互质,这就是n*(n-1)*(n-3),只要比较两者谁更大就可以了
 
 
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define ll long long

int main()
{
    ll n,ans,i;
    while(~scanf("%lld",&n))
    {
        if(n == 1)
        {
            printf("1\n");
            continue;
        }
        else if(n == 2)
        {
            printf("2\n");
            continue;
        }
        else if(n == 3)
        {
            printf("6\n");
            continue;
        }
        if(n%2)
            ans = n*(n-1)*(n-2);
        else
        {
            ans = (n-1)*(n-2)*(n-3);
            ans = max(ans,n*(n-1)*(n-3));
        }
        printf("%lld\n",ans);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值