ZOJ3541:The Last Puzzle(区间DP)

There is one last gate between the hero and the dragon. But opening the gate isn't an easy task.

There were n buttons list in a straight line in front of the gate and each with an integer on it. Like other puzzles the hero had solved before, if all buttons had been pressed down in any moment, the gate would open. So, in order to solve the puzzle, the hero must press all the button one by one.

 After some trials, the hero found that those buttons he had pressed down would pop up after a while before he could press all the buttons down. He soon realized that the integer on the button is the time when the button would automatic pop up after pressing it, in units of second. And he measured the distance between every button and the first button, in units of maximum distance the hero could reach per second. Even with this information, the hero could not figure out in what order he should press the buttons. So you talent programmers, are assigned to help him solve the puzzle.

To make the puzzle easier, assuming that the hero always took integral seconds to go from one button to another button and he took no time turnning around or pressing a button down. And the hero could begin from any button.

Input

The input file would contain multiple cases. Each case contains three lines. Process to the end of file.

The first line contains a single integer n(1 ≤ n ≤200), the number of buttons.

The second line contains n integers T1T2, ..., Tn, where Ti(1 ≤ Ti ≤ 1,000,000) is the time the ith button would automatic pop up after pressing it, in units of second.

The third line contains n integers D1D2, ..., Dn, where Di(1 ≤ Di ≤ 1,000,000) is the time hero needed to go between the ith button and the first button, in units of second. The sequence will be in ascending order and the first element is always 0.

Output

Output a single line containing n integers which is the sequence of button to press by the hero. If there are multiply sequences, anyone will do. If there is no way for the hero to solve the puzzle, just output "Mission Impossible"(without quote) in a single line.

Sample Input
2
4 3
0 3
2
3 3
0 3
4
5 200 1 2
0 1 2 3
Sample Output
1 2
Mission Impossible
1 2 4 3
Hint

In the second sample, no matter which button the hero pressed first, the button would always pop up before he press the other button. So there is no way to make all the button pressed down.


题意:一排在一条献上的开关,要把所有开关全部按下的步骤,每移动一个单位距离需要一个单位时间,给出每个开关的位置,并且每个开关按下后经过一定的时间又会弹起来,求出步骤

思路:dp[i][j][k]表示把i,j全部按下花费的时间,k=0表示停在i,k=1表示停在j,再开个next进行路径记录,跟ZOJ3469类似


#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define up(i,x,y) for(i=x;i<=y;i++)
#define down(i,x,y) for(i=x;i>=y;i--)
#define mem(a,b) memset(a,b,sizeof(a))
#define w(x) while(x)
#define ss(x) scanf("%d",&x)
const int inf = 1<<30;
int dp[205][205][2],t[205],d[205],next[205][205][2];

int main()
{
    int i,j,k,l,n;
    w(~scanf("%d",&n))
    {
        up(i,1,n)
        ss(t[i]);
        up(i,1,n)
        ss(d[i]);
        mem(dp,0);
        up(l,2,n)
        {
            up(i,1,n-l+1)
            {
                j=i+l-1;
                dp[i][j][0]=min(dp[i+1][j][0]+d[i+1]-d[i],dp[i+1][j][1]+d[j]-d[i]);
                next[i][j][0]=(dp[i+1][j][0]+d[i+1]-d[i]>=dp[i+1][j][1]+d[j]-d[i]);
                if(dp[i][j][0]>=t[i] || dp[i][j][0]>inf)
                    dp[i][j][0]=inf;
                dp[i][j][1]=min(dp[i][j-1][1]+d[j]-d[j-1],dp[i][j-1][0]+d[j]-d[i]);
                next[i][j][1]=(dp[i][j-1][0]+d[j]-d[i]>=dp[i][j-1][1]+d[j]-d[j-1]);
                if(dp[i][j][1]>=t[j] || dp[i][j][1]>inf)
                    dp[i][j][1]=inf;
            }
        }
        int l,r,m;
        if(dp[1][n][0]<inf)
        {
            l=2,r=n,m=next[1][n][0];
            printf("1");
        }
        else if(dp[1][n][1]<inf)
        {
            l=1,r=n-1,m=next[1][n][1];
            printf("%d",n);
        }
        else
            printf("Mission Impossible");
        while(l<=r)
        {
            if(m==0)
            {
                printf(" %d",l);
                m=next[l][r][m];
                l++;
            }
            else
            {
                printf(" %d",r);
                m=next[l][r][m];
                r--;
            }
        }
        printf("\n");
    }

    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值