HDU4952:Number Transformation

Problem Description
Teacher Mai has an integer x.

He does the following operations k times. In the i-th operation, x becomes the least integer no less than x, which is the multiple of i.

He wants to know what is the number x now.
 

Input
There are multiple test cases, terminated by a line "0 0".

For each test case, the only one line contains two integers x,k(1<=x<=10^10, 1<=k<=10^10).
 

Output
For each test case, output one line "Case #k: x", where k is the case number counting from 1.
 

Sample Input
  
  
2520 10 2520 20 0 0
 

Sample Output
  
  
Case #1: 2520 Case #2: 2600
找规律= =
#include <stdio.h>

int main()
{
    __int64 a,b,cas=1,i,j;
    while(~scanf("%I64d%I64d",&a,&b),a+b)
    {
        i=2;
        while(i<=b)
        {
            if(a%i)
            {
                j=a/i+1;
                if(j<=i)
                {
                    a=j*b;
                    break;
                }
                a=i*j;
            }
            else
            {
                j=a/i;
                if(j<=i)
                {
                    a=j*b;
                    break;
                }
            }
            i++;
        }
        printf("Case #%I64d: %I64d\n",cas++,a);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值