POJ2002:Squares

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property. 

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates. 

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1
 
枚举两个相邻的点,求出另外两点,再看这两个点是否存在
 
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define up(i,x,y) for(i=x;i<=y;i++)
#define down(i,x,y) for(i=x;i<=y;i++)
#define mem(a,b) memset(a,b,sizeof(a))
#define w(a) while(a)
const int mod=20007;
int n,next[20007],head[20007],m,ans;
struct node
{
    int x,y;
} a[2222];
int cmp(node a,node b)
{
    if(a.x==b.x)
        return a.y<b.y;
    return a.x<b.x;
}
void insert(int i)
{
    int key=(a[i].x*a[i].x+a[i].y*a[i].y)%mod;
    next[m]=head[key];
    a[m].x=a[i].x;
    a[m].y=a[i].y;
    head[key]=m++;
}

int find(int x,int y)
{
    int key=(x*x+y*y)%mod;
    for(int i=head[key];i!=-1;i=next[i])
    if(a[i].x==x&&a[i].y==y)
    return i;
    return -1;
}

int main()
{
    int i,j;
    w((scanf("%d",&n),n))
    {
        mem(head,-1);
        mem(next,0);
        m=1005;
        ans=0;
        up(i,0,n-1)
        {
            scanf("%d%d",&a[i].x,&a[i].y);
            insert(i);
        }
        sort(a,a+n,cmp);
        up(i,0,n-1)
        {
            up(j,i+1,n-1)
            {
                int x1,y1,x2,y2;
                x1=a[i].x-a[j].y+a[i].y;
                y1=a[i].y+a[j].x-a[i].x;
                if(find(x1,y1)==-1)
                continue;
                x2=a[j].x-a[j].y+a[i].y;
                y2=a[j].y+a[j].x-a[i].x;
                if(find(x2,y2)==-1)
                continue;
                ans++;
            }
        }
        printf("%d\n",ans/2);
    }

    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值